Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 7 years ago

#7467 closed defect (bug) (no action required)

Group photo code not Generating to update an existing groups photo.

Reported by: pandraka's profile pandraka Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

Once the group is created, I can't update the group photo, some of the code isn't being generated. I've disabled all the plugins and change the theme, the outcome is the same. When creating a new group I can upload a photo. When updating an existing group's photo I can't. It seems that some of the code isn't generating. I've attached captures of both a group creation and group photo update. When the code is generated for the group photo updates, the code for bp-avatar-nav and bp-avatar-status are missing.

  1. Which version of WordPress are you running?

4.6.1

  1. Did you install WordPress as a directory or subdomain install?

directory

  1. If a directory install, is it in root or in a subdirectory?

root

  1. Did you upgrade from a previous version of WordPress? If so, from which version?

4.6

  1. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.

Yes

  1. Which version of BP are you running?

2.8.2 - but the issue was discovered on 2.8.1 I don't know whent this became an issue since I didn't test for this feature before hand

  1. Did you upgraded from a previous version of BP? If so, from which version?

2.8.1

  1. Do you have any plugins other than BuddyPress installed and activated? If so, which ones?

Yes

  1. Are you using the standard WordPress theme or customized theme?

Skeleton, with a child theme.

  1. Which theme do you use ?

Skeleton

  1. Have you modified the core files in any way?

No

  1. Do you have any custom functions in bp-custom.php?

No

  1. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?

2.5.11

  1. Please provide a list of any errors in your server’s log files.
  1. Which company provides your hosting?

inmotion

  1. Is your server running Windows, or if Linux; Apache, nginx or something else?

Basic Trouble Shooting:

Before posting your question please run some essential trouble shooting.
These steps are essential to correctly identifying where the issue might lie and it’s essential that they are done in advance of any questions being raised, also running a search on keywords related to your issue might return previous threads that could help.

  1. Identifying whether you have a theme issue: Many issue are often custom theme related, it is important to determine if this is the case with your issue; to do this please activate a theme that is known to behave correctly with BuddyPress, that will be any theme that is in the default install from WP so choose either ‘twentytweleve, ‘twentythirteen’ or a later one. Having activated one of these theme check again if you still have the same issue, if you haven’t then this tells us it’s theme related, and in the first instance you should contact the theme author for help. If no help is forthcoming from the theme author then certainly post a question on the BP help forum, but please bear in mind forum support is limited where third party themes are concerned.

Not a theme issue, I have the same result with 2015

  1. Plugins: many issues are caused by plugins, especially where JavaScript is concerned to try and narrow things down deactivate all plugins non essential to BP functioning and then re-active one by one until the issue reappears. I've disabled all the plugins and still have the issue

Change History (1)

#1 @r-a-y
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed
  • Version 2.8.2 deleted

Hi @pandraka,

Thanks for creating this ticket, but can you post this on the support forums instead?

I tested this on Twenty Twelve and group photos work as expected.

Note: See TracTickets for help on using tickets.