Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7465 closed defect (bug) (no action required)

Groups still can't have the same slugs as pages/posts

Reported by: matcho's profile matcho Owned by: dcavins's profile dcavins
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords: close
Cc: dcavins

Description

This is a follow-up to #2123.

Hi,

A little topic excavation here :)
Even though it could not be reproduced back in the days, the bug is still here.

Walkthrough

  • created a group named interesting-stuff
  • created a page named "Interesting stuff", having the URL /interesting-stuff
  • created a subpage of /foo named "Interesting stuff", having the URL /foo/interesting-stuff

The problem

  • visit /interesting-stuff : OK
  • visit /foo/interesting-stuff : OK
  • visit /groups/interesting-stuff : redirects to /interesting-stuff

WP generates a 301 redirection in this case.

Other groups are accessible as expected, and non-existing groups whose slug doesn't correspond to any WP page give a 404.

I didn't try using posts instead of pages as it is not my use case.

Thanks a lot for any advice,
Greetings,

Mathias

(WP 4.7.3, BP 2.8.1, theme Twentysixteen)

Change History (6)

#1 @dcavins
7 years ago

  • Cc dcavins added

#2 @dcavins
7 years ago

  • Owner set to dcavins
  • Status changed from new to accepted

#3 @dcavins
7 years ago

Hi @matcho-

Thanks for your report and very clear steps to reproduce. Using a vanilla installation, I'm seeing these results:

I created a group "captain" and a page "captain".
http://bptest.local/captain/ resolves to the page, http://bptest.local/groups/captain/ resolves to the group.

Then I made "captain" a child page of "commodore" as your steps read.
http://bptest.local/commodore/captain/ resolves to the page, http://bptest.local/groups/captain/ resolves to the group.

What happens if you flush your permalink structure? Does the problem continue? (I'm using "Month and name" style permalinks. What are you using?)

Are you using any plugins (or themes) that modify rewrites? In your test environment, are you running anything besides BuddyPress?

Thanks!

-David

#4 @matcho
7 years ago

  • Keywords close added
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from accepted to closed

Hi @dcavins

Thanks a lot for your quick answer.

We use a lot of plugins, yes... after disabling them one at a time, it happened that the issue was caused by Remove Category URL.

All apologies for not checking this before; thanks again for your help.
Marked as invalid and closed.

Greetings,
Mathias

#5 @dcavins
7 years ago

Hi @matcho-

Thanks for following up. I used to use a plugin that I think does the same thing, called FV Top Level Categories, that I don't think ever caused this kind of collision.

Best of luck!

#6 @matcho
7 years ago

Hi,

A little follow-up here, just for information : the case seems more complicated. Disabling "Remove category URL" restores access to the group, but breaks the other pages; flushing the permalinks afterwards restores access to the pages... but breaks the group again.

Disabling "WPML Multilingual CMS" seems to fix the issue, and is permalink-flushing proof. Crap! I need this plugin :-/

Anyway, you say the issue is not reproducible with a vanilla install so it's not a BP bug. Thanks for the advice about "FV Top Level Categories".

Mathias

Note: See TracTickets for help on using tickets.