Skip to:
Content

Opened 6 months ago

Last modified 6 months ago

#7457 reopened defect (bug)

BuddyPress Duplicated 'Groups' and 'Messages'

Reported by: wpjasper Owned by:
Milestone: Priority: high
Severity: major Version: 2.8.0
Component: Core Keywords:
Cc:

Description

Hello, Everyone

A pleasant morning to all of you, and I hope that all of you are doing well.

A while ago, I had experienced an issue with regards to duplication of Groups and Messages.

When submitting a form, I have clicked the 'Submit' button many times, and I had noticed that the 'Submit' button does not have 'Disabled' attribute when the 'Submit' button is clicked. So, as a result, the 'Groups' and 'Messages' had duplicated data.

To reproduce the issue:
Go to 'Group Creation' page, fill-up the fields and click the 'Create Group and Continue' button twice or many times.

GO to the 'User Profile Compose Message' page, fill-up the fields and click the 'Send Message' button twice or many times.

Suggested Solution:
Add a 'Disabled' attribute to the 'Submit' button of all fields when clicked, to avoid duplication of form submission and data.

Duplicated Groups
http://imgur.com/nYL5bOW.png

Duplicated Messages
http://imgur.com/EQGNazC.png

I hope I had explained very well the details of this issue.

All the Best,

Jasper

Change History (3)

#1 @hnla
6 months ago

  • Milestone Awaiting Review deleted
  • Priority changed from highest to normal
  • Resolution set to worksforme
  • Severity changed from critical to normal
  • Status changed from new to closed

@wpjasper Thanks for the ticket.

Couple of problems initially:

  1. Your screen shots show a custom theme, so we have the problem of whether it might be the theme creating the issue?
  1. I fail to re-create the issue on a standard install running under a WP twenty seventeen stock theme.

The way the group creation steps works is to move one on to a new screen after the submission so it's quite hard to click multiple times, even if managing to multiple submissions don't occur.

To test whether it's your theme you need to activate a standard WP twenty* theme against which we know the basic BP plugin works and is tested against and while ensuring all plugins other than BP are deactivated.

If the problem clears up then you'll, need to check with the themes author asking them to look into the issue. If the issue persists then please re-open this ticket.

#2 @dunhakdis
6 months ago

  • Priority changed from normal to high
  • Resolution worksforme deleted
  • Severity changed from normal to major
  • Status changed from closed to reopened

@hnla

I can replicate this issue in any theme including twenty seventeen and twenty sixteen.

(Twentyseventeen Theme)

https://s24.postimg.org/55c1n2xsl/Screen_Shot_2017_03_03_at_4_19_33_PM.png

Actually, this is very easy to replicate. I agree that it is hard to replicate on localhost since everything runs fast. But on live hosting, the submission takes a few seconds making it easy to click on the submit button multiple times, thus creating multiple or duplicate groups.

Suggestion:

Create a javascript click event that will disable the submit button once it is submitted.

Thanks!

This ticket was mentioned in Slack in #buddypress by dunhakdis. View the logs.


6 months ago

Note: See TracTickets for help on using tickets.