Skip to:
Content

BuddyPress.org

Opened 15 years ago

Closed 10 years ago

#743 closed enhancement (duplicate)

Ability to block user on various actions

Reported by: takuya's profile takuya Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc: sam3dus@…

Description

Ability to block:

  • receiving messages from a specific user
  • viewing of profile

Simply "Block This Person" button just like "add friend" on each profile to block that user would be nice.

Change History (8)

#1 @johnjamesjacoby
15 years ago

  • Owner set to johnjamesjacoby
  • Status changed from new to assigned

Auths are in the works.

#2 @(none)
15 years ago

  • Milestone Future Enhancements deleted

Milestone Future Enhancements deleted

#3 @johnjamesjacoby
14 years ago

  • Owner johnjamesjacoby deleted

Since auths didn't make it into 1.2 and Jeff has the most knowledge on this one, I'm unassigning myself until further notice.

#4 @cnorris23
14 years ago

  • Component set to Core
  • Milestone set to 1.3

#5 @boonebgorges
13 years ago

  • Milestone changed from 1.3 to Future Release

If someone offered up a good patch for this, I'd be very happy. As it stands, it should be accomplishable by plugin (either Jeff's BP Privacy or a simpler one) so I don't imagine that core dev time will go toward it for 1.3.

#6 @r-a-y
11 years ago

  • Keywords dev-feedback added; block removed
  • Priority changed from minor to normal
  • Severity set to normal

Need to figure out a proper storage mechanism before we do anything for this.

eg. CPT or custom DB table or usermeta (probably drop the latter from consideration)

CPT makes most sense.

#7 @shanebp
11 years ago

  • Cc sam3dus@… added

#8 @r-a-y
10 years ago

  • Keywords dev-feedback removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Marking this a duplicate of #5665 since that ticket has some design specs.

Note: See TracTickets for help on using tickets.