Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

#7414 closed defect (bug) (fixed)

"Order by" filters are broken for objects directories

Reported by: slaFFik Owned by: boonebgorges
Milestone: 2.8 Priority: high
Severity: normal Version:
Component: Templates Keywords: needs-patch dev-feedback
Cc:

Description

For members/groups(/blogs?) directories the "type" value is always "active", regardless of what is selected.
Same for Friends list in profile etc.

BuddyPress 2.7.4 doesn't have this issue.
Current trunk - does have.

Change History (8)

#1 @slaFFik
3 years ago

Caused by r11356.

#2 @slaFFik
3 years ago

  • Keywords needs-patch dev-feedback added
  • Priority changed from normal to high

@boonebgorges, will you be able to take a look at this?
Changes in buddypress-functions.php caused this issue.

#3 @slaFFik
3 years ago

  • Component changed from Core to Templates

#4 @hnla
3 years ago

Tested reverting out that revision and trunk kicks back in for order by filters.

#5 @slaFFik
3 years ago

Only changes in bp_legacy_theme_ajax_querystring() are relevant to this issue.

#6 @boonebgorges
3 years ago

  • Owner set to boonebgorges
  • Status changed from new to assigned

#7 @boonebgorges
3 years ago

Confirmed. The type stuff should be outside of the action check.

#8 @boonebgorges
3 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 11377:

AJAX directory 'type' should not depend on 'action' whitelist.

Introduced in [11356], via some overzealous cutting and pasting.

Props slaFFik, hnla.
Fixes #7414.

Note: See TracTickets for help on using tickets.