Skip to:
Content

#7341 closed defect (bug) (wontfix)

404 instead of login screen

Reported by: atmojones Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Route Parser Keywords:
Cc:

Description

To reproduce: clean wordpress install, buddypress plugin, 2016 theme. Login and go to a restricted area (i.e. http://example.com/members/[username]/settings/ ), and everything looks fine. Log out and revisit the URL and instead of being prompted to log in you are given a 404 page.

Change History (1)

#1 @slaFFik
14 months ago

  • Component changed from Members to Route Parser
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
  • Version 2.7.2 deleted

This is by design. BuddyPress doesn't have UI for in-page login scenario, only in a widget.
Restricted area should not exist for logged out users, that is why it returns 404.
I believe you can dive into hooks and redefine this behaviour, if you need.

Note: See TracTickets for help on using tickets.