Skip to:
Content

#7339 closed enhancement (fixed)

Upgrade jquery bgiframe

Reported by: wpdennis Owned by: slaffik
Milestone: 2.8 Priority: normal
Severity: normal Version:
Component: Messages Keywords:
Cc: info@…

Description

BuddyPress includes jquery.bgiframe version 2.1.2. This version uses jQuery.browser(), which was deprecated in jQuery 1.3 and removed in jQuery 1.9:
http://jquery.com/upgrade-guide/1.9/#jquery-browser-removed

The current version 3.0.1 of jquery.bgiframe says it needs jQuery >= 1.2.6:
https://github.com/brandonaaron/bgiframe/blob/master/jquery.bgiframe.js

jQuery 1.2.6+ was included since WordPress WP 2.6 and since WordPress 3.6 the jQuery version comes without jQuery.browser():
http://core.svn.wordpress.org/tags/3.6/wp-includes/js/jquery/jquery.js

Maybe it's time for an upgrade. :-)

Change History (2)

#1 @slaFFik
14 months ago

  • Keywords dev-feedback removed
  • Milestone changed from Awaiting Review to 2.8

WordPress 4.2 (our minimal version we support) has jQuery 1.11.2.
We will upgrade this.

#2 @slaffik
13 months ago

  • Owner set to slaffik
  • Resolution set to fixed
  • Status changed from new to closed

In 11373:

Messages: Upgrade jquery bgiframe.

WordPress 4.2 (our minimal version we support) has jQuery 1.11.2. jquery.bgiframe v3.0.1 (current latest) says it needs jQuery >= 1.2.6.

Props wpdennis.
Fixes #7339.

Note: See TracTickets for help on using tickets.