Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 5 years ago

#7270 closed defect (bug) (wontfix)

BuddyPress Child pages not inheriting page features from parent.

Reported by: Venutius Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords: reporter-feedback
Cc:

Description

A couple of years ago when you set up BudyPress, you could set the Members page as having a different format (i.e. three columns rather than say the default of two) and this format would flow down to the child pages.

In other words, you could set the members page to have three columns and this would mean the members profile page would also have three columns.

However, this behaviour has changed and setting a new page format for the members page only affects the members directory, the user profile page now reverts to the theme default layout.

It this a bug or deliberate?

Change History (7)

#1 @sbrajesh
5 years ago

Hi,
It was never a behavior of BuddyPress. if it happened, It was most probably a theme feature BuddyPress layouts for different page use their own template hierarchy. Please see this document to make it work for your theme.

https://codex.buddypress.org/themes/theme-compatibility-1-7/template-hierarchy/

Hope that helps.

#2 @espellcaste
5 years ago

Indeed it wasn't a BuddyPress "thing". It appears it was a theme feature...

#3 @DJPaul
5 years ago

  • Keywords reporter-feedback added

Hmm.

@Venutius When you say "setting a new page format", what part of the user interface do you mean? Do you mean the "Page Template" dropdown when editing a Page inside wp-admin?

#4 @Venutius
5 years ago

Yes, I'd like set a three column template for the members profile pages for example, I've tried several ways of doing this and failed each time. When I first set up my site two years ago I simply choose the three column layout for the members and this flowed down to the members profile pages. I know this is correct because I was using WP Profile Widgets in that area for users to set some profile personalisation but I seem to be getting told that this would have never worked. Yet I had users setting their profile widgets and having them displayed in the third column (site default has always been a two column layout.

#5 @DJPaul
5 years ago

In other words, you could set the members page to have three columns and this would mean the members profile page would also have three columns.

@r-a-y Any idea if the $wp_query[post]->id = 0 change we/you made for tempting some years ago would have had this affect? Because prior to this, I think we were setting WP's main query's post ID to the ID of the mapped BP page for all pages under the subcomponents?

#6 @r-a-y
5 years ago

Any idea if the $wp_query[post]->id = 0 change we/you made for tempting some years ago would have had this affect?

Yes it would.

Because prior to this, I think we were setting WP's main query's post ID to the ID of the mapped BP page for all pages under the subcomponents?

This is correct. I would mark this as a duplicate of #6230.

For what I would recommend, see https://buddypress.trac.wordpress.org/ticket/6230#comment:15.


For Venutius' issue, I would recommend using BP's template hierarchy for single pages instead:
https://codex.buddypress.org/template-hierarchy/

Last edited 5 years ago by r-a-y (previous) (diff)

#7 @DJPaul
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thanks @r-a-y!

@Venutius To answer your question: this is a consequence of an intentional change we made elsewhere, which we are not planning to revert back to at this point in time. I'm sorry it took us a while to remember the cause, and for the inconvenience caused. Hopefully some of what Ray suggested may help you devise a workaround.

Note: See TracTickets for help on using tickets.