Skip to:
Content

BuddyPress.org

Opened 3 years ago

Last modified 3 years ago

#7230 new defect (bug)

Custom language file or directory is not processed first after updating to Wordpress 4.6

Reported by: krista7 Owned by:
Milestone: Awaiting Contributions Priority: normal
Severity: normal Version: 2.6.2
Component: I18N Keywords: needs-patch
Cc:

Description

After updating to Wordpress version 4.6 the custom Buddypress language file located in wp-content\languages\buddypress is not processed first anymore, as is stated in https://codex.buddypress.org/translations/.

Custom language file works with
Wordpress version 4.5.3
Buddypress version: 2.6.2

Custom language file doesn't work with
Wordpress version: 4.6
Buddypress version: 2.6.2

Steps to reproduce the problem: Use older Wordpress version than 4.6. Make a custom text and open the page so that you can see your custom text. Update Wordpress to 4.6 and reload the page. Now your custom text is gone and the default text is there instead. In my case I expect to see my custom text on the registration page but I see the default text instead.

The problem occurs when all plugins except Buddypress are deactivated and with all default themes (Twenty Fourteen, Twenty Fifteen, Twenty Sixteen) and plugins, themes and translations are up to date.

Change History (3)

#1 @DJPaul
3 years ago

  • Component changed from (not sure) to I18N
  • Milestone changed from Awaiting Review to Under Consideration

Please look at #WP37819, this is caused by a change in WordPress 4.6.

We'll keep this open until that ticket is resolved one way or another.

This ticket was mentioned in Slack in #buddypress by dcavins. View the logs.


3 years ago

#3 @DJPaul
3 years ago

  • Milestone changed from Under Consideration to Future Release
Note: See TracTickets for help on using tickets.