Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

#7172 closed defect (bug) (worksforme)

Woocommerce checkout AJAX and Buddypress AJAX are in conflict

Reported by: egyptimhotep's profile egyptimhotep Owned by: imath's profile imath
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords: needs-testing needs-patch reporter-feedback
Cc:

Description

The only way how to fix is to disable ajax woocommerce checkout.

<?php
/**
 * Disable checkout script, because of conflict BuddyPress and Woocommerce Ajax conflict.
 */
function disable_checkout_script(){
    wp_dequeue_script( 'wc-checkout' );
}
add_action( 'wp_enqueue_scripts', 'disable_checkout_script' );

Change History (3)

#1 @imath
8 years ago

  • Owner set to imath
  • Status changed from new to assigned

Hi egyptimhotep

Thanks for your feedback. I will look at this asap.

#2 @imath
8 years ago

  • Keywords reporter-feedback added

I just checked with WooCommerce 2.6.2. I don't see any conflict.

I was able to proceed to checkout.
I was able to post activities, reorder the groups...

Could you share a way to reproduce the issue ?

#3 @DJPaul
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.