Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

#7134 closed defect (bug) (fixed)

bp_blogs_can_comment_reply() uses wrong method when checking activity comment depth

Reported by: r-a-y Owned by: r-a-y
Milestone: 2.7 Priority: normal
Severity: normal Version: 2.0
Component: Blogs Keywords: has-patch commit
Cc:

Description

If blog comment sync is enabled and the "Enable threaded comments X levels deep" option is checked under the dashboard's "Settings > Discussion" page, the activity comment "Reply" link does not accurately display.

The issue is when comparing WP comment depth to see if an activity entry can be commented to, the current method checks against the mptt_left DB field. This isn't accurate.

We should use the bp_activity_get_comment_depth() function instead.

Attachments (1)

7134.01.patch (560 bytes) - added by r-a-y 3 years ago.

Download all attachments as: .zip

Change History (4)

@r-a-y
3 years ago

This ticket was mentioned in Slack in #buddypress by r-a-y. View the logs.


3 years ago

#2 @DJPaul
3 years ago

  • Keywords commit added

Looks good to me

#3 @r-a-y
3 years ago

  • Owner set to r-a-y
  • Resolution set to fixed
  • Status changed from new to closed

In 10947:

Blogs: Fix issue with calculating activity comment depth.

If blog comment sync is enabled and the "Enable threaded comments X levels
deep" option is checked under the dashboard's "Settings > Discussion" page,
the activity comment "Reply" link does not accurately display in the
activity stream.

Problem was using the wrong method to compare the comment depth, which is
rectified in this commit.

Fixes #7134.

Note: See TracTickets for help on using tickets.