Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

#7122 closed defect (bug) (worksforme)

Activity thread replies broken when post is displayed multiple times on same screen

Reported by: timeuser Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.0
Component: Activity Keywords: reporter-feedback
Cc:

Description

When viewing the main activity screen and the same post shows up in multiple places you can't reply to it or the reply form shows up in the wrong place. Attached is a screenshot showing a scenario to reproduce the issue. In the screenshot Post "A" is displayed twice because the active user was @mentioned in it and also @mentioned in a parent post and we are viewing the mentions feed. Clicking reply under that post either does nothing or opens incorrectly under the other copy of the post. This behavior is broken randomly and differently depending on how many copies of the post are displayed on the screen. My guess is the ID being used to grab the post by javascript isn't unique.

Attachments (1)

activityDuplicatePosts.png (290.9 KB) - added by timeuser 3 years ago.
Screenshot

Download all attachments as: .zip

Change History (9)

@timeuser
3 years ago

Screenshot

#1 @r-a-y
3 years ago

You shouldn't be able to see activity replies on activity comments. This isn't default behavior.

For example:
http://tinyimg.io/i/cd5hCkN.png

Notice that there isn't any replies shown underneath?

#3 @DJPaul
3 years ago

  • Component changed from API to Core

#4 @DJPaul
3 years ago

  • Component changed from Core to Activity
  • Keywords reporter-feedback added

#5 @DJPaul
3 years ago

This sounds like it's something customised in a template that hasn't handled this exception to where we don't allow replies. @timeuser what theme are you using?

#6 @timeuser
3 years ago

The screenshot above is from the WordPress Twenty Fifteen theme. We're using the Boss theme by BuddyBoss on our live site and the issue is there also.

#7 @DJPaul
3 years ago

BuddyBoss is looking into this from their end.

#8 @DJPaul
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I never heard from BuddyBoss if they identified the issue or not, other than they confirmed they customised the template. I couldn't recreate this on other themes, so we'll need to wait to hear from them.

Note: See TracTickets for help on using tickets.