Skip to:

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7103 closed defect (bug) (fixed)

Embeds: rename `BP_oEmbed_Component` class

Reported by: djpaul's profile DJPaul Owned by: r-a-y's profile r-a-y
Milestone: 2.6 Priority: normal
Severity: normal Version:
Component: Core Keywords:


Please can the BP_oEmbed_Component class be renamed to BP_Core_oEmbed_Component?
That way, it'll get picked up by the autoloader, then we can remove the require_once hack at the top of class-bp-activity-oembed-component.php.

I really dislike the oEmbed capitalisation but will let it pass because it's more readable this way.

I also dislike the fact this class is called a "component" which has a very specific meaning in BuddyPress, but I don't have a better suggestion.

Change History (4)

#1 @r-a-y
8 years ago

Thanks for the feedback.

Maybe rename to BP_Core_oEmbed_Extension to be similar to BP_Group_Extension?

#2 @DJPaul
8 years ago

sounds good

#3 @r-a-y
8 years ago

  • Owner set to r-a-y
  • Resolution set to fixed
  • Status changed from new to closed

In 10849:

Embeds: Rename classes to change Component to Extension.

Props DJPaul.

Fixes #7103.

#4 @DJPaul
8 years ago

  • Component changed from API to Core
Note: See TracTickets for help on using tickets.