Skip to:
Content

BuddyPress.org

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#710 closed defect (bug) (worksforme)

Recent SVN update caused minor bp-activity.php include error

Reported by: ev3rywh3re's profile ev3rywh3re Owned by:
Milestone: Priority: trivial
Severity: Version: 1.0
Component: Keywords:
Cc:

Description

I've been doing automated SVN merge updates for WPMU, bbPress, and BuddyPress for some time. My recent update to [1444] caused a minor issue that was easily fixed, but I though I should note what happened.

The update caused an include error for bp-activity.php which I easily fixed by temporarily adding the following code to bp-activity.php:

if ( !defined( 'BP_PLUGIN_DIR' ) ) {
	/* Define the path and url of the BuddyPress plugins directory */
	define( 'BP_PLUGIN_DIR', WP_PLUGIN_DIR . '/buddypress' );
	define( 'BP_PLUGIN_URL', WP_PLUGIN_URL . '/buddypress' );
}

Once added I could then access the site and site admin where I found the BuddyPress plugin deactivated.

I then reactivated the BuddyPress Plugin sitewide and removed the code above. Everything worked perfectly.

I can only guess that this was caused by WPMU plugin administration changes, but I thought I should note it in trac in case it needs a deeper look.

Change History (2)

#1 @apeatling
15 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I don't think this will be a problem so I'm closing, thanks for noting it though.

#2 @(none)
15 years ago

  • Milestone Core 1.0 deleted

Milestone Core 1.0 deleted

Note: See TracTickets for help on using tickets.