Skip to:
Content

BuddyPress.org

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#7021 closed enhancement

gruntfile: Watch Task- lets watch the scss files

Reported by: hnla Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords:
Cc:

Description

Patch adds a watch task to gruntfile.js with an initial task watching any changes to *.scss files to run the sass task compiling to .css.

Attachments (1)

7021.patch (376 bytes) - added by hnla 4 years ago.
Add a watch task to gruntfile.

Download all attachments as: .zip

Change History (6)

@hnla
4 years ago

Add a watch task to gruntfile.

#1 @DJPaul
4 years ago

See also #6382

#2 @hnla
4 years ago

Hmm ok hadn't realised that existed, not sure why this seems such a complex thing, this patch simply sets 'watch' to compile the scss file changes to css file, if the BP requirements are more complicated than that due to ? 'build' task then better leave this ticket.

#3 @DJPaul
3 years ago

  • Milestone changed from 2.6 to Future Release

#4 @netweb
3 years ago

  • Milestone Future Release deleted
  • Status changed from new to closed

Duplicate of #6382, the patch in 6382 already includes SCSS files in the watch task

#5 @DJPaul
3 years ago

  • Component changed from Tools - Build Process to Build/Test Tools
Note: See TracTickets for help on using tickets.