Skip to:

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#7008 closed defect (bug) (fixed)

Bump NodeJS LTS 4.x.x as the minimum supported NodeJS version

Reported by: netweb Owned by: djpaul
Milestone: 2.6 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: has-patch


Via #WP35105 Specify minimum node and npm version in package.json

WordPress will also be bumping to the 4.2.x LTS branch of NodeJS (ref)

This ticket adds NodeJS version 4.2.1 as the minimum supported NodeJS version per the initial 4.2.x LTS branch release announcement here, see also

Various NPM packages already require greater than the default Travis CI installed version 0.10.32:

  • node-sass - "node": ">=0.10.40"
  • grunt-check-dependencies - "node": ">=0.12.7 <0.13 || >=4.1.0"
  • postcss - "node": ">=0.12
  • stylelint - "node": ">=0.12
  • autoprefixer - "node": ">=0.12

Attachments (1)

7008.diff (932 bytes) - added by netweb 6 years ago.

Download all attachments as: .zip

Change History (4)

6 years ago

#1 @netweb
6 years ago

  • Component changed from API to Tools - Build Process
  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 2.6

#2 @djpaul
6 years ago

  • Owner set to djpaul
  • Resolution set to fixed
  • Status changed from new to closed

In 10703:

Specify minimum node and npm version in package.json.

Some of the NPM packages we use have minimum versions of node. This can lead to notices when a developer does an npm install on a machine with an older version of NPM, or when the grunt-check-dependencies task runs.

Fixes #7008

Props netweb

#3 @DJPaul
5 years ago

  • Component changed from Tools - Build Process to Build/Test Tools
Note: See TracTickets for help on using tickets.