Skip to:
Content

BuddyPress.org

Opened 4 years ago

Closed 3 years ago

#6983 closed defect (bug) (no action required)

Failing UX for replying to an activity-comment item's replies

Reported by: Offereins Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Activity Keywords: reporter-feedback
Cc: lmoffereins@…

Description

In a member's activity stream, replies to activity items are listed as activity-comment items. Follow-up (child) replies to the original comment are displayed as well, but without the entire conversation's context. Since an activity-comment item exists within the context of the original activity item it replied to, users cannot reply to the single activity item. This is why for activity-comment items the 'Reply' link and the reply form are not present.

However, the follow-up (child) replies of the acvitity-comment item *do* have a 'Reply' link present. While this is in itself confusing without the conversation's context, this renders a failing UX as there is no reply form present in the context of the activity item.

To solve this, we can best remove the 'Reply' link for the activity-comment item replies. Another solution is to remove the follow-up (child) replies entirely from the activity item.

PS. This might only apply to installations with nested commenting enabled.

Attachments (2)

6983.1.patch (664 bytes) - added by Offereins 4 years ago.
Skip on activity_comment activity type in bp_activity_can_comment_reply()
6983.2.patch (525 bytes) - added by Offereins 4 years ago.
Filter bp_acivity_can_comment_reply() with bp_activity_can_comment()

Download all attachments as: .zip

Change History (11)

@Offereins
4 years ago

Skip on activity_comment activity type in bp_activity_can_comment_reply()

@Offereins
4 years ago

Filter bp_acivity_can_comment_reply() with bp_activity_can_comment()

#1 @Offereins
4 years ago

  • Keywords has-patch added

#2 @DJPaul
4 years ago

  • Milestone changed from Awaiting Review to 2.6

#3 @DJPaul
4 years ago

@Offereins Does this only apply to activity items created by the sync-comments-to-activity-stream feature?

I tried to set up a series of activity updates and replies but I couldn't reproduce what you said it currently does. Maybe could you provide step-by-step instructions? Thanks.

#4 @DJPaul
4 years ago

  • Keywords reporter-feedback added
  • Milestone changed from 2.6 to Under Consideration

#5 @Offereins
4 years ago

  • Keywords reporter-feedback removed

Hi @DJPaul, I had to test to make sure it wasn't the theme. But using a default theme, nothing changes.

Try the following steps, while allowing for nested comments of at least 3 levels deep.

  1. User A creates a public activity update (or have it already present).
  2. User B replies to the public activity update. This adds a new activity item of type activity_comment in user B's activity stream.
  3. User A (or B) replies to the reply (nested comments) created in step 2.
  4. Go to the activity thread of user B, view the activity item from step 2 and try to create a reply to the reply created in step 3. Notice, there is no reply form.
Last edited 4 years ago by Offereins (previous) (diff)

#7 @DJPaul
4 years ago

  • Milestone changed from Under Consideration to Awaiting Review

#8 @DJPaul
4 years ago

  • Keywords reporter-feedback added; has-patch removed
  • Milestone changed from Awaiting Review to Under Consideration

@Offereins I hate to see abandoned tickets with patches, but I could never recreate what you were trying to describe. Do you want to take a stab at for BP 2.8? The problem we have is that no-one else in 7 months has commented on the ticket, so we don't know if it is truly an issue (or something specific to the site you were testing on), or whether we were not correctly recreating the steps that you tried to describe.

I'd suggest maybe recording a video, so we can step-by-step. That should make it easy to confirm or deny. :)

#9 @DJPaul
3 years ago

  • Milestone Under Consideration deleted
  • Resolution set to invalid
  • Status changed from new to closed

See previous comments. If we can figure out recreate it, we can fix it.

Note: See TracTickets for help on using tickets.