Skip to:
Content

BuddyPress.org

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#6926 closed defect (bug) (no action required)

PHP Notice: bp_setup_current_user was called incorrectly

Reported by: mrjarbenne Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

I'm testing 2.5 RC and seeing this error in my logs. I've deactivated all other plugins. Thought it was worth reporting.

[24-Feb-2016 13:46:22 UTC] PHP Notice: bp_setup_current_user was called <strong>incorrectly</strong>. The current user is being initialized without using $wp->init(). Please see <a href="https://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress</a> for more information. (This message was added in version 1.7.) in /var/www/domain.com/wordpress/wp-includes/functions.php on line 3792

Change History (3)

#1 @slaFFik
4 years ago

Related to #6046 and a bunch of similar issues in repo.

#2 @r-a-y
4 years ago

  • Milestone 2.5 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing this.

This specific instance was being caused by a WP mu-plugin:
https://buddypress.org/support/topic/error-in-release-candidate-2-5/#post-250259

#3 @DJPaul
3 years ago

  • Component changed from API to Core
Note: See TracTickets for help on using tickets.