Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6916 closed defect (bug) (no action required)

Emojis, smileys and links in activities

Reported by: imath's profile imath Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

If i post an activity containing a link and emojis: no problem
http://imath-buddypress.wpserveur.net/members/iphone/activity/107/

If i post an activity containing a link + a smiley: no problem
http://imath-buddypress.wpserveur.net/members/iphone/activity/109/

But if i post an activity containing a link + a smiley + an emoji, i get an error
https://cldup.com/Wla9r6TFdg.png

Change History (5)

#1 @r-a-y
8 years ago

imath - I cannot duplicate this on Firefox and Chrome on desktop.

I also tried your test site with Firefox on Android and it worked:
http://imath-buddypress.wpserveur.net/activity/p/111/

Perhaps the problem is with the emoji you are using? What browser are you using and on what device?

#2 @imath
8 years ago

it fails on iPhone 6 Safari iOS

Last edited 8 years ago by imath (previous) (diff)

#3 @r-a-y
8 years ago

I think it has to do with the emoji you are using, imath.

In your screenshot, you are using the "Thinker Face" emoji, which is Unicode-8:
http://emojipedia.org/thinking-face/

I just tried copying and pasting this emoji into the activity stream and also got the error message on desktop.

According to the Docblock, wp_encode_emoji() only works for Unicode-7 emojis.

There is a ticket in core that might address this - #WP35293. (Also see #WP33592.)

In the meantime, for our release notes for v2.5, we might want to list something about only supporting Unicode-7 emojis.

Last edited 8 years ago by r-a-y (previous) (diff)

#4 @imath
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks a lot r-a-y. Let's do this.

Last edited 8 years ago by imath (previous) (diff)

#5 @DJPaul
8 years ago

  • Component changed from API to Core
Note: See TracTickets for help on using tickets.