Skip to:
Content

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#691 closed defect (bug) (invalid)

home theme preview not displaying

Reported by: DJPaul Owned by:
Milestone: Priority: major
Severity: Version: 1.0
Component: Keywords:
Cc:

Description

DJPaul: ok well I am stuck getting RC2 working. Is anyone able to assist?
[20:25] jjj: Sure what's up
[20:27] DJPaul: Very beginnings. new install of everything, new db. chmod'd eeverything to 755 so hopefully permissions are ok. Moved theme into wp-content/themes/buddypress-home and the member theme into wp-content/bp-themes/buddypress-member.
[20:27] DJPaul: I go into WP and enable BP (and all the modules but that's the default anyway). I go into the Themes admin, allow use of the BP how themes, then go to Manage Themes and click on the 'buddypress default home theme' to select that as the home theme for hte main blog.
[20:27] DJPaul: Then you get the preview up with "activate bp default home theme in the top-right"
[20:28] DJPaul: The preview is entirely white. I'm inspecting the dom and it hasn't loaded any of the html for the preview
[20:28] DJPaul: it just does the first <body> tag then nothing else
[20:28] DJPaul: I saw someone saying this on the forums earlier too
[20:29] DJPaul: no errors in apache log
[20:29] jjj: Yep, it's a bug.
[20:29] jjj: The theme will activate though.
[20:29] jjj: My guess is functions.php is mucking it up, because of the home.php file.
[20:29] DJPaul: dyou kow if anyone has put a ticket on for this? quick look can't see it
[20:30] jjj: Not sure, but it's been this way for a while.
[20:30] DJPaul: k
[20:30] jjj: Since using the trunk anyhow.
[20:30] DJPaul: i'll do a ticket then

Change History (3)

comment:1 DJPaul5 years ago

OK so spent ages investigating. Got no where. All the preview frame does( is load ( http://example.com/?preview=1&template=buddypress-user&stylesheet=buddypress-user& ). Tried pulling out functions.php, no effect. Tried putting minimum (bp_core_load_template) from functions.php into top of index.php and/or home.php, no effect. URL's not missing a nonce. Only effects BuddyPress Home theme, not one of the standard bundled WP themes. eventually found where wp does the ?preview bit. wp-includes/theme.php line 868 if anyone cares.

have fun

comment:2 DJPaul5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

WPMU bug - http://trac.mu.wordpress.org/ticket/965 - props jjj for tracking it down.

comment:3 anonymous5 years ago

  • Milestone Default Home Theme 1.0 deleted

Milestone Default Home Theme 1.0 deleted

Note: See TracTickets for help on using tickets.