Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 6 years ago

#6862 closed idea (no action required)

Super Sticky Topics on Group Forums and Group Forums in bbPress Shortcodes

Reported by: garrett-eclipse Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Forums Keywords:
Cc:

Description

Hello,

Wanted to raise into discussion how Super Sticky topics and bbPress forum Shortcode is handled within BuddyPress as it created some confusion for me.

Giving a bit of background first, I'm using the WPLMS theme by Vibe which marries bbPress with BuddyPress and utilizes the functionality they provide to create course CPTs which can be tied into Groups and Forums. I've set-up a single bbPress forum for Support, and Group Forums to provide the Courses with unique forums. On the Courses I have a subpage which pulls the Group Forum into the Course via the bbp-single-forum shortcode. I used a Super Sticky bbPress topic to share a topic across all my forums. At first this appeared casually as I was only really looking at the Course Forum as generated by the shortcode. When a course ends we block the course but provide the forum and resources through the group for ongoing support. This raised to light the fact that my Super Sticky topic wasn't being listed on the actual Group Forum.

So my issue originally was going to indicate that the Super Sticky topics weren't being listed on the Group Forum, which @netweb confirmed was explicitly disabled/removed from group forums. I can live with this.

What I'd like to raise for discussion is if they were removed from Group Forums, and Group Forums can be pulled in via the bbPress shortcode, should they not also be removed from the shortcode representation of this Group Forum so they're consistent and list the same topics?
*Or maybe is there a BuddyPress version of the single-forum shortcode I should use instead?

My main concern is the consistency between the two representations of the same forum. In this case it's concerning Super Sticky, but mayhap there's other bbPress functions disabled for BuddyPress that are evident in a Group Forum that's displayed via the shortcode.

Greatly appreciated,
Cheers
P.S. Sharing my discussion with @netweb concerning this topic;

garrett-eclipse [4:33 PM] 
Hey guys, sorry to bother. Hoping to get some help understanding sticky topics before logging an issue.
When I have a topic set to Super Sticky I notice it appearing on forums created by the [bbp-single-forum id=$forum] shortcode. But if I navigate to the Group Forum (exact same forum) it’s not displaying.
Correct me if wrong but Super Sticky is supposed to show on ALL forums right?

netweb [4:34 PM] 
Not sure, but I don’t think so in regard to group forums ¯\_(ツ)_/¯

garrett-eclipse [4:40 PM] 
Thanks @netweb, definitely confused. Would expect it to be consistent considering both forums although in different locations are the exact same one under the covers one is just presented via shortcode and the other in Group

[4:43] 
And another minor issue in association. If Super Sticky is to be shown on all forums I noticed in the shortcode version which does show the Super Sticky that even though it has that topic there’s still a notice saying 'THIS FORUM IS EMPTY.'

netweb [4:44 PM] 
@garrett-eclipse: Super-stickies are explicitly disabled/removed for group forums (looking at the code now)

netweb [4:45 PM] 
The `THIS FORUM IS EMPTY.` is a #bbpress issue but it is correct non the less, the sticky topic is ​_not_​ in ​_that_​ forum

garrett-eclipse [4:45 PM] 
Thanks @netweb what are your thoughts in the case of a Group Forum being pulled in through the bbp-single-forum shortcode

[4:46] 
true enough on the emptiness. Visually deceiving for a user however as they’re unaware of that

netweb [4:47 PM] 
Typically a forum is not empty so ¯\_(ツ)_/¯

garrett-eclipse [4:48 PM] 
Agreed, not important to me. Mainly looking at making consistency between my Group Forum and the Forum Shortcode that pulls that Group Forum.
Is there a BuddyPress version of the bbp-single-forum shortcode

netweb [4:51 PM] 
The issue with using shortcodes such as `[bbp-single-forum id=$forum]` with BP groups is that (like the super sticky) thing above bbPress tweaks a few things to work with BuddyPress as best it can, be it permissions, form fields, permalinks, privacy, activity etc

[4:52] 
Then using the bbPress shortcodes directly circumvents the BP integration

garrett-eclipse [4:54 PM] 
Thanks for the explaination @netweb I’ll avoid use of Super Sticky as there’s no point in my set-up. I only have one bbPress forum (Support) the rest are all BuddyPress ones which don’t support it anyway (aside from their shortcode representations)

[4:55] 
@netweb: Is there anything worthy of opening a trac ticket around this to be followed up on in the future?

netweb [4:58 PM] 
@garrett-eclipse: Maybe, though including a use case for context of what your trying to achieve versus the current functionality would help explain things as there really aren’t any bugs in the way things are currently

garrett-eclipse [5:00 PM] 
Sounds good thx @netweb

new messages
netweb [5:00 PM] 
:+1:

Change History (1)

#1 @r-a-y
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 2.4.0 deleted

Thanks for the extensive write-up, Garrett.

However, since BuddyPress doesn't touch bbPress code (bbPress offers BuddyPress support, not the other way around), you should post your issue about Super Stickies and its integration into BP group forums on bbPress Trac:
https://trac.bbpress.org

Note: See TracTickets for help on using tickets.