Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 6 years ago

#6849 closed enhancement (maybelater)

Changing a post author doesn't affect the activity entry

Reported by: sgr33n's profile SGr33n Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.4.0
Component: Activity Keywords: good-first-bug, trac-tidy-2018
Cc:

Description

Hi people :)

If you change the author of a blog post, the activity entry will remain on the old author. If you change the post status to draft and then to published again the activity owner will change to the new one.

Change History (8)

#1 @boonebgorges
8 years ago

What's the expected behavior? It's a bit weird: the activity item says "Boone published a blog post", and changing the post author to "Joe" after the fact doesn't change the fact that Boone published it initially :)

#2 @SGr33n
8 years ago

You're right, but it's also right that the post is not anymore a Boone's post, the boone's post doesn't exist anymore, now it is the joe's post.

#3 @DJPaul
8 years ago

  • Milestone changed from Awaiting Review to Under Consideration

#4 @DJPaul
8 years ago

  • Milestone changed from Under Consideration to Awaiting Review

#5 @DJPaul
8 years ago

  • Keywords good-first-bug added
  • Milestone changed from Awaiting Review to Future Release
  • Type changed from defect (bug) to enhancement

We should sort this out.

#6 @tw2113
8 years ago

Wouldn't this require updating the table column value for the activity item? Perhaps, if there's some template of sorts for the activity content, we could do a function that grabs that template and fills in new values of a provided user and updates the table column. It'd remove need for complex regex by simply replacing completely.

#7 @DJPaul
6 years ago

  • Keywords trac-tidy-2018 added

We're closing this ticket because it has not received any contribution or comments for at least two years. We have decided that it is better to close tickets that are good ideas, which have not gotten (or are unlikely to get) contributions, rather than keep things open indefinitely. This will help us share a more realistic roadmap for BuddyPress with you.

Everyone very much appreciates the time and effort that you spent sharing your idea with us. On behalf of the entire BuddyPress team, thank you.

If you feel strongly that this enhancement should still be added to BuddyPress, and you are able to contribute effort towards it, we encourage you to re-open the ticket, or start a discussion about it in our Slack channel. Please consider that time has proven that good ideas without contributions do not get built.

For more information, see https://bpdevel.wordpress.com/2018/01/21/our-awaiting-contributions-milestone-contains/
or find us on Slack, in the #buddypress channel: https://make.wordpress.org/chat/

#8 @DJPaul
6 years ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to maybelater
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.