Skip to:
Content

BuddyPress.org

Opened 4 years ago

Closed 4 years ago

#6819 closed defect (bug)

update error

Reported by: danbp Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Toolbar & Notifications Keywords:
Cc: danco38@…

Description

When a member/subscriber publish more than one link in an update, he got an error and the update is not published.
If he post only one link, the update is published without problem.

If the site admin does the same thing, the update is always published, whatever the number of links.

I got this behave with all WP themes. I see also on 2 lines:
-1
There was a problem posting your update[...]

Seems coming from bp_legacy_theme_post_update() in buddypress-functions.php

This error msg is fired when activity_id is empty. I don't understand the relation between a user status and the creation of an update when the user is logged in...

May not be a bug, but i'm interrested to know the reason of such a restriction. And if it is a restriction, it would be better to show something other than "There was a problem..." and also, to let the site owner decide if he want to apply a restriction or not for what's new updates/notices.

To reproduce this:
login as subscriber and publish 2 links. (on profile or group)
Then publish only one link.
Logout and login as admin and do the same.

Change History (1)

#1 @boonebgorges
4 years ago

  • Milestone Awaiting Review deleted
  • Status changed from new to closed

Thanks for the detailed report, @danbp. I believe this is a duplicate of #6719.

Note: See TracTickets for help on using tickets.