Skip to:
Content

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#6805 closed enhancement (fixed)

Bump minimum WP version to 3.9

Reported by: boonebgorges Owned by: boonebgorges
Milestone: 2.5 Priority: normal
Severity: normal Version:
Component: Core Keywords: 2nd-opinion
Cc:

Description

Previously: #6258

To update the stats reported at https://buddypress.trac.wordpress.org/ticket/6258#comment:9, here are the current usage numbers for each version of WordPress which BP currently has official support for, and which was released over one year ago:

3.8: 3.6% (2013-12-12)
3.9: 5.0% (2014-04-16)
4.0: 5.4% (2014-09-04)
4.1: 8.4% (2014-12-18)

I vote we act conservatively and drop official support for WP 3.8 in BP 2.5. Any objections? (By the looks of things, 2.6 may be able to bump WP requirements to 4.1.)

See also https://codex.buddypress.org/getting-started/wordpress-version-compatibility/

Change History (4)

#2 @DJPaul
2 years ago

Sure, go for it.

Heads-up that my email stuff has a small reliance on 4.0-code, but we can talk about that when I finish that work.

#3 @boonebgorges
2 years ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from new to closed

In 10436:

Bump minimum WP requirement to 3.9.

Fixes #6805.

#4 @DJPaul
2 years ago

  • Component changed from API to Core
Note: See TracTickets for help on using tickets.