Skip to:
Content

Opened 2 years ago

Closed 3 months ago

Last modified 3 months ago

#6753 closed defect (bug) (wontfix)

Ajax pagination fails when a members loop is used inside the plugins.php template

Reported by: henry.wright Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.4.0
Component: Templates Keywords:
Cc:

Description

To reproduce the problem...

Add a new screen to the main nav. The screen_function I used:

function my_screen() {
    add_action( 'bp_template_content', 'my_template_part' );
    bp_core_load_template( 'members/single/plugins' );
}

function my_template_part() {
    bp_get_template_part( 'members/members-loop' );
}

As you can see, I'm using the plugins.php template and injecting the members-loop into it. I'm filtering this particular members loop via bp_after_has_members_parse_args.

If a no-ajax class is added to the #pag-top and #pag-bottom elements, then pagination works, else pagination doesn't work.

Change History (4)

#1 @DJPaul
23 months ago

  • Component changed from Not sure to Appearance - Template Parts
  • Milestone changed from Awaiting Review to Future Release

Haven't tested but will take your word. Not awfully surprised there are (more) problems with BuddyPress' legacy pagination scripts (which I assume you're using), but probably won't fix this until we rebuild the template pack in the future -- unless someone really wants to figure out how we could fix this. :)

#2 @DJPaul
16 months ago

  • Component changed from Appearance - Template Parts to Templates

#3 @DJPaul
3 months ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Closing most tickets related to BP-Default and BP-Legacy, since the upcoming BP-Nouveau template pack (planned for 3.0) will make these redundant.

#4 @DJPaul
3 months ago

Closing most tickets related to BP-Default and BP-Legacy, since the upcoming BP-Nouveau template pack (planned for 3.0) will make these redundant.

Note: See TracTickets for help on using tickets.