Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6710 closed defect (bug) (fixed)

notices-loop

Reported by: danbp Owned by: hnla
Milestone: 2.4 Priority: normal
Severity: normal Version:
Component: Toolbar & Notifications Keywords:
Cc: danco38@…

Description

BP 2.4 rc1
Twenty Sixteen

  • the notice delete message button use x instead of Delete Message.

This x is in the same column as activate/deactivate status and isn't pertinent (at least to me) when it comes as second line under the action name. Should at least be in a separate column if the aim is to gain some place. That said i ignore why this part is styled like this, as the similar one for message management is slightly different, and much better.

The template itself looks awful on Twenty Sixteen and contains some useless tags like strong and a mysterious empty td of 1% !

Here the code with real content of what i'm speaking about.

<tbody><tr id="notice-2" class="">
   <td width="1%"></td>
      <td width="38%">
	<strong>This is a notice to all users.</strong>
	<p>This is a notice test to all users.</p>
      </td>
      <td width="21%">
       <strong></strong>
       <span class="activity">Sent: 2 November 2015 at 17 h 44 min</span>
      </td>
      <td width="10%">
       <a class="button" href="http://wpbeta/members/daniel/messages/notices/deactivate/2/?_wpnonce=227dc95ecc">Deactivate</a>
       <a class="button" href="http://wpbeta/members/daniel/messages/notices/delete/2?_wpnonce=ded41a06e5" title="Delete Message">x</a>
      </td>
   </tr>
</tbody>

Concerned file is notices-loop

Attachments (4)

notice-loop.jpg (17.2 KB) - added by danbp 5 years ago.
notice loop on twenty sixteen
messages-notices-table-wide.jpg (77.9 KB) - added by hnla 5 years ago.
This is the widescreen view of a re-factored set of styles to counter the incorrect % widths and inherited display and float values.
messages-notices-table-mobile.jpg (55.5 KB) - added by hnla 5 years ago.
Same layout at mobile/small screen view
messages-notices-table-wide-revised.jpg (71.5 KB) - added by hnla 5 years ago.
Final revision - in keeping with the styles for message-threads on other companion sheets

Download all attachments as: .zip

Change History (15)

@danbp
5 years ago

notice loop on twenty sixteen

#1 @danbp
5 years ago

Note that the above described issue doesn't apply to 2014 and 2015, (text on button is correct) but is again in 2013, 2012 et 2011.

#2 @imath
5 years ago

@hnla could you look at it, i think the layout for twentysixteen could be improved :)

#3 @hnla
5 years ago

@danbp Thanks for the heads up I'm looking into it.

@imath & @danbp Part of the problem is that I don't see the same issue at all and see some missing elements, Dan are you templates fully up to date they aren't overloaded?

#4 @hnla
5 years ago

Scrub that was looking at notifications screen, instead of messages *sigh*

Haven't a clue why that looks so bad, but sadly looks like some work to fixup.

On the question of templates or markup we can't touch that for the companion styles, I'd earmarked a lot of markup like this for overhaul and re-writing in a new set of templates.

Any patches gratefully accepted :)

Last edited 5 years ago by hnla (previous) (diff)

#5 @hnla
5 years ago

  • Owner set to hnla
  • Status changed from new to assigned

#6 @danbp
5 years ago

My templates are daily updated on my local beta test site. ;-)

@hnla
5 years ago

This is the widescreen view of a re-factored set of styles to counter the incorrect % widths and inherited display and float values.

@hnla
5 years ago

Same layout at mobile/small screen view

#7 @hnla
5 years ago

With a few more minor tweaks this will probably be the best we can do with this for the moment the markup really needs to be updated.

My templates are daily updated on my local beta test site. ;-)

Yep sorry I was just being very slow :)

#8 @hnla
5 years ago

Revising the updated corrections to use the styles for message threads from the previous companion styles which maintains the same styles for sitewide-notices as message-threads, in porting styles across that were missed.

I'll be committing and closing this shortly.

@hnla
5 years ago

Final revision - in keeping with the styles for message-threads on other companion sheets

#9 @hnla
5 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 10325:

Twentysixteen Companion Styles correction

Update corrects an issue where message-thread sitewide-notices table styles not ported over for twentysixteen.

Fixes #6710 Props danbp

This ticket was mentioned in Slack in #buddypress by mercime. View the logs.


5 years ago

#11 @hnla
5 years ago

  • Milestone changed from Awaiting Review to 2.4
Note: See TracTickets for help on using tickets.