Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#6706 closed defect (bug) (wontfix)

2015 theme issues with Forum component (bbPress 2.x)

Reported by: slaffik's profile slaFFik Owned by: hnla's profile hnla
Milestone: Priority: normal
Severity: normal Version:
Component: Templates Keywords:
Cc:

Description (last modified by slaFFik)

Some problems with styles, see attached screenshots

On BuddyPress trunk & WordPress v4.4-beta2-35481
*and*
On BuddyPress v2.3.4 & WordPress v4.3.1

Attachments (5)

2015-11-01 14.05.01.png (84.4 KB) - added by slaFFik 8 years ago.
2015-11-01 14.09.46.png (25.4 KB) - added by slaFFik 8 years ago.
bp-2.3.4.png (79.9 KB) - added by slaFFik 8 years ago.
BuddyPress v2.3.4, WordPress v4.3.1, 2015 v1.3
2015-11-01 14.49.31.png (199.8 KB) - added by slaFFik 8 years ago.
2015-11-01 14.50.10.png (156.0 KB) - added by slaFFik 8 years ago.

Download all attachments as: .zip

Change History (20)

#1 @DJPaul
8 years ago

  • Keywords reporter-feedback added

@slaFFik an you test with BP 2.3.x and let us know if this is a regression in 2.4 or not?

#2 @slaFFik
8 years ago

@DJPaul Sure, will do that right now.

@slaFFik
8 years ago

BuddyPress v2.3.4, WordPress v4.3.1, 2015 v1.3

#3 @slaFFik
8 years ago

@DJPaul Same problems with BuddyPress 2.3.4

#4 @slaFFik
8 years ago

  • Description modified (diff)

#5 @DJPaul
8 years ago

  • Component changed from Component - Forums to Appearance - Template Parts
  • Keywords needs-patch added; reporter-feedback removed
  • Milestone changed from Awaiting Review to 2.5

Thanks for checking!

#6 @hnla
8 years ago

  • Owner set to hnla
  • Status changed from new to assigned

@slaFFik This is a difficult one in some regards.

The companion styles were intended to address BP styles when displayed in twenty* themes.

They weren't intended to address styles that might arise from third party plugins or code.

bbPress sits oddly between being third party in it's own styles and templates and standalone in plugin nature, however being unique in being a plugin that is deeply integrated into BP as more of a component.

The issue is one where bbpress styles conflict with the twentyfifteen themes styles rather than with anything buddypress is or isn't doing.

The dilemma is whether to address these as part of the companion styles task, I think we have to to some extent due to the close affiliation and display within BP content areas, however having looked at this it's going to be a case where it's not correcting styles but having to go a little deeper and address general layout aspects.

That I think is a separate task, I'll look at what we can do during 2.5 cycle to improve things but think styling bbPress has to be kept limited.

#7 @slaFFik
8 years ago

@hnla Yeah, you are absolutely right here.
My thoughts were that core-dev team already did some tweaks in code to make BuddyPress work correctly with other plugins (like actions changes for WordPress SEO by Yoast plugin), so I believe some fixes for bbPress can be made as well (especially because it is so integrated with BP).

#8 @hnla
8 years ago

True we did take into account Yoast when we were having to work out the wp_title() issues but if you read the ticket it was more because our changes and the way Yoast was working were going to conflict with each other.

Some changes can and should be made but have to be very careful as there are actually more than meet the eye, and my cursory check had me looking at quite a few areas to deal with and when you start one it will tend to spiral into quite a few more and also possibly for the other themes as well.

But we'll look to include some updates in 2.5.

#9 @netweb
8 years ago

You'll find if you test these without BuddyPress activated you'll still see some of these problems with bbPress ;)

#10 @DJPaul
8 years ago

  • Milestone changed from 2.5 to 2.6

#11 @DJPaul
8 years ago

  • Milestone changed from 2.6 to Future Release

#12 @DJPaul
8 years ago

  • Component changed from Appearance - Template Parts to Templates

#13 @slaFFik
7 years ago

  • Keywords close added

@hnla
Can we come back to this, or lets mark as closed, as we basically not integrating with all 3rd party plugins?

My second feeling is to close this, because:
1) pretty sure no real life communities will use default WordPress themes for their site, because they are too basic and just showcase new vision and WordPress functionality over the past year
2) in my understanding integration with twenty... themes is an example of how everything can work and be displayed, so there is no an ultimate goal to make those themes perfect for production
3) taking into account latest comment by @netweb (bbPress styling issues)

Last edited 7 years ago by slaFFik (previous) (diff)

#14 @hnla
7 years ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from assigned to closed

Agreed and yes netweb's point was important some styling issues exist regardless of BP activation so that supports the case that we can't necessarily be correcting styles arising from third party work.

Twenty* supporting styles were intended as a necessity to ensure that BP didn't have any huge styling conflicts with what are default WP themes and where BP really should display as well as possible i.e we know the themes and can test for them unlike unknown themes that may be chosen; however I do think that probably twenty* themes are used as a base set of templates styles to build quite often, but then if the theme isn't a child of i.e we wouldn't load the companion styles.

I'll close this as a 'WontFix'

#15 @slaFFik
7 years ago

  • Keywords needs-patch close removed
Note: See TracTickets for help on using tickets.