Skip to:
Content

BuddyPress.org

Opened 4 years ago

Closed 3 years ago

#6705 closed defect (bug) (fixed)

WP-Admin menu mess when both Legacy forum and bbPress activated

Reported by: slaFFik Owned by: slaffik
Milestone: 2.8 Priority: normal
Severity: normal Version:
Component: Forums Keywords: good-first-bug
Cc:

Description

When users have legacy group forum component activated and bbPress at the same time - they get duplicated Settings -> Forums menu item, which is frustrating.

Perhaps, we need to rename Legacy forum settings link to Legacy Forum?

Attachments (1)

2015-11-01 13.59.23.png (23.1 KB) - added by slaFFik 4 years ago.

Download all attachments as: .zip

Change History (4)

#1 @DJPaul
4 years ago

  • Keywords needs-patch good-first-bug added
  • Milestone changed from Awaiting Review to Future Release

We can change our integration in bp_forums_add_admin_menu and change the label to something like "Forums (Legacy)".

#2 @slaFFik
3 years ago

  • Keywords needs-patch removed
  • Milestone changed from Future Release to 2.8

#3 @slaffik
3 years ago

  • Owner set to slaffik
  • Resolution set to fixed
  • Status changed from new to closed

In 11296:

Legacy Forums: rename the menu item under Settings.

When both Legacy forum and bbPress 2.x activated - we have a duplicated "Forums" menu item, for each of forums instances.
Changing the label of the legacy forum bbPress 1.x menu item (and page title) to "Forums (Legacy)".

Fixes #6705.

Note: See TracTickets for help on using tickets.