Skip to:
Content

BuddyPress.org

Opened 4 years ago

Last modified 4 years ago

#6703 new defect (bug)

Installing old fashioned bbPress 1.x from BuddyPress installation

Reported by: slaFFik Owned by:
Milestone: Awaiting Contributions Priority: normal
Severity: normal Version:
Component: Forums Keywords: needs-patch
Cc:

Description

When trying to use bbPress that is shipped with BuddyPress I go through forum installation logic, but have this code to add to bb-config.php file (on Windows it was unable to create the file, which is really strange).

-1
$bb->custom_user_table = 'wp_users';
$bb->custom_user_meta_table = 'wp_usermeta';

$bb->uri = 'http://trunk.bp/wp-content/plugins/buddypress/build//bp-forums/bbpress/';
$bb->name = 'BuddyPress Trunk Forums';

define('BB_AUTH_SALT', '=(.gWbVY2$j_8i)`.Q052,0EY[iRTKZ7JOaJ1I{ZY,JF^P1y&oPkc4+y5g/<{v-Z');
define('BB_LOGGED_IN_SALT', 'J~BS(0W.{.5 3U>t];SG,g]t())~Z;6rE$nB;3 (x@C<}::<#SvqNk-r2eC f;6/');
define('BB_SECURE_AUTH_SALT', 'DU-<s}oI<Ul8At$r+);N4`Dg]i0Sl_I5-vWZoSN6kU4vIQT6/8[5++}!<geX:-ea');

define('WP_AUTH_COOKIE_VERSION', 2);

?>

Note 2 problems here: -1 instead of <?php and double slash in url to bbPress buddypress/build//bp-forums.
Shouldn't there be something like global $bb;?

Change History (5)

#1 @slaFFik
4 years ago

  • Summary changed from Intalling old fashioned bbPress 1.x from BuddyPress installation to Installing old fashioned bbPress 1.x from BuddyPress installation

#2 @slaFFik
4 years ago

Also, according to a comment by @DJPaul https://buddypress.trac.wordpress.org/ticket/6704#comment:3 some constants are also missing.

#3 @DJPaul
4 years ago

  • Milestone changed from Awaiting Review to Future Release

No-one's touched bp_forums_bbpress_install() in years so I wouldn't be surprised if there wasn't edge cases around the bb-config.php creation process. For example, the -1 comes from bp_forums_bbpress_write() if /bp-forums/bbpress/bb-config-sample.php' doesn't exist.

Are you running a release build of BuddyPress, or trunk? bbPress is only present in the release packages, so I could see this failing on a trunk version.

#4 @slaFFik
4 years ago

I was running trunk. I noticed that only on #6704, after that I downloaded latest stable version and just copied bbPress directory from there to current BuddyPress trunk.
So yes, this issue might be caused only by the lack of bbPress files.
But then this is another bug - BuddyPress successfully installing bbPress 1.x when there are actually no bbPress 1.x at all :)

Last edited 4 years ago by slaFFik (previous) (diff)

#5 @DJPaul
4 years ago

  • Keywords needs-patch added

At the very least, we ought to improve the error handling so we don't print error return codes like the -1 and -2 to the config file.

Note: See TracTickets for help on using tickets.