Skip to:
Content

BuddyPress.org

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#665 closed defect (bug) (fixed)

Long group descriptions interfere with other elements in group directory

Reported by: burtadsit's profile burtadsit Owned by:
Milestone: Priority: minor
Severity: Version: 1.0
Component: Keywords:
Cc:

Description

I was helping someone in the forums create an excerpt of the group description: http://buddypress.org/forums/topic.php?id=2114

As I was playing with an excerpt filter I noticed that the description can run into the 'join/leave group' area of the directory. I suck at css.

Attachments (1)

665-position-fix.patch (1.2 KB) - added by lancewillett 15 years ago.

Download all attachments as: .zip

Change History (8)

#1 @burtadsit
15 years ago

I give up for the day.

#2 @nicolagreco
15 years ago

  • Milestone set to Groups 1.0
  • Version set to 1.0

#3 @apeatling
15 years ago

  • Milestone changed from Groups 1.0 to Default Member Theme 1.0

#4 @lancewillett
15 years ago

This issue is caused by the fact that the "action" area with the join/leave button, group types, and member count is not floated to the right but instead uses absolute positioning to pin it there. Thus when the text in the group description is long it can overlap with the action area.

Rather than change the CSS to use floats, a fairly straightforward fix would be to move the group type and member count to the same area as the "activity" text. That way the only item on the right is the join/leave button, which isn't tall enough to cause problems with the paragraph text of the group's description.

See attached patch for how to rearrange the text to avoid this overlap issue.

#5 @apeatling
15 years ago

Thanks for the patch. It's actually quite easy to fix this by adding a percentage width value to the containing box. The change you made in the patch could be done on a site by site basis though, as this is all template based.

#6 @apeatling
15 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [1353]) Fixes #665

#7 @(none)
15 years ago

  • Milestone Default Member Theme 1.0 deleted

Milestone Default Member Theme 1.0 deleted

Note: See TracTickets for help on using tickets.