Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#6614 closed defect (bug) (fixed)

Default "selected" class removed from nav tabs by buddypress.js

Reported by: davidtcarson Owned by: r-a-y
Milestone: 2.3.4 Priority: normal
Severity: normal Version: 2.3.0
Component: Templates Keywords: has-patch commit
Cc:

Description

When no cookies for activity or directories (groups, members) exist, the default "selected" class is removed from the item list tabs by buddypress.js. To test, clear cookies or log out.

Appears to be caused by strict comparisons added in [9528] (changeset) checking for null against uninitialized resulting in type mismatch.

Attachments (2)

6614.diff (2.0 KB) - added by davidtcarson 5 years ago.
nav-no-cookie.png (26.7 KB) - added by davidtcarson 5 years ago.
screenshot

Download all attachments as: .zip

Change History (11)

@davidtcarson
5 years ago

@davidtcarson
5 years ago

screenshot

#1 @davidtcarson
5 years ago

  • Component changed from API to General - UX/UI

#2 follow-up: @DJPaul
5 years ago

NIce patch! Pretty certain we have 2 other tickets for things relating to this issue, not that I can find them.

Last edited 5 years ago by DJPaul (previous) (diff)

#3 in reply to: ↑ 2 @davidtcarson
5 years ago

Replying to DJPaul:

NIce patch! Pretty certain we have 2 other tickets for things relating to this issue, not that I can find them.

#6143 (ticket) and #6508 (ticket) appear to be related.

Last edited 5 years ago by davidtcarson (previous) (diff)

#4 @DJPaul
5 years ago

  • Milestone changed from Awaiting Review to 2.4

#5 @r-a-y
5 years ago

  • Component changed from General - UX/UI to Appearance - Template Parts
  • Keywords has-patch commit added
  • Milestone changed from 2.4 to 2.3.4
  • Version set to 2.3.0

davidtcarson - Nice catch!

Looks like this bug was introduced in 2.3.0. So we should add this fix in 2.3.4.

Marked #6143 and #6508 as duplicates.

When jq.cookie('bp-activity-filter') doesn't exist, it returns undefined not null so David's fix is correct.

Last edited 5 years ago by r-a-y (previous) (diff)

This ticket was mentioned in Slack in #buddypress by r-a-y. View the logs.


5 years ago

#7 @r-a-y
5 years ago

  • Owner set to r-a-y
  • Resolution set to fixed
  • Status changed from new to closed

In 10132:

bp-legacy: Change strict cookie checks to undefined instead of null.

Fixes an issue where no default tab is selected on a BuddyPress directory
page when no cookie is set.

Props davidtcarson.

Fixes #6614 (2.3-branch).

#8 @r-a-y
5 years ago

In 10133:

bp-legacy: Change strict cookie checks to undefined instead of null.

Fixes an issue where no default tab is selected on a BuddyPress directory
page when no cookie is set.

Props davidtcarson.

See #6614 (trunk).

#9 @DJPaul
4 years ago

  • Component changed from Appearance - Template Parts to Templates
Note: See TracTickets for help on using tickets.