Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#6573 closed defect (bug) (no action required)

Activity stream image display problem

Reported by: Pete Hudson Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3.2
Component: Core Keywords:
Cc:

Description

Hi guys. Shortly after updating to BP 2.3.2, we've been having an issue with the alignment of images on the BP activity stream on posts that inherited from our blog posts. The images should be (and have previously always been) aligned left as they are in the blog posts. Not featured images, but embedded left at the very beginning of blog posts.

Since updating to 2.3.2, the images are sometimes aligned center and sometimes aligned right in the activity stream and the images are fine in the actual blog post.

I started out posting this issue to the forum: https://buddypress.org/support/topic/problem-with-blog-post-image-alignment/#post-242545 and Henry suggested I open this ticket.

Here's a login to the site, if someone can take a look:

http://marketingrebelclub.com
UN: TestU
PW: Testpw2015

We haven't made any other changes to the site aside from the recent WP maintenance upgrade.

Attached is an image of two blog posts, the exact same content, one posted two weeks ago with good alignment and another one published recently with the center alignment.

Any help or insight would be appreciated.

Thanks.

http://marketingrebelclub.com/wp-content/uploads/2015/07/BP-post-formattig-issue.jpg

Change History (5)

#1 @hnla
5 years ago

It's due to recent changes to how media is handled in BP activity streams, the problem is the removal of image attr such as class tokens and the image name references the WP image size.

#2 @henry.wright
5 years ago

@hnla, I had a quick look at the source of the actual post. The image element was placed before the text in the post content. However, with reference to the activity item, it seems BuddyPress is placing the image element after the text.

#3 @hnla
5 years ago

@henry.wright yes aware of the issue ( if all elements were in paragraph markup the last paragraph would be removed), had to look at it on a client site, I've raised/mentioned this in a ticket but haven't had time to really delve into this as no one else seemed aware of the issue.

#4 @DJPaul
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

@Pete Hudson I assume you updated to BP 2.3.2 from a 2.2 version (or older). These changes were made in BP 2.3 but they'll only affect newly generated items, not old ones. I'm sorry for the inconvenience caused, but this is all working as intended.

Yes, old releases had the CSS tags on elements when they were being pulled into the activity stream. They won't now. The concern was they would be used out of their original context (i.e. the blog post).

Also, the images are being explicitly moved after the excerpt (i.e. at the bottom) which is different than before you - you could previously see them almost anywhere.

These changes were made for consistency, and you'll need to add custom CSS to tweak the appearance.

#5 @DJPaul
4 years ago

  • Component changed from API to Core
Note: See TracTickets for help on using tickets.