Skip to:
Content

Opened 3 years ago

Last modified 22 months ago

#6557 new defect (bug)

Soft hyphen prevents recording of blog post in activity

Reported by: schwarzaufweiss Owned by:
Milestone: Future Release Priority: normal
Severity: minor Version: 2.3.2
Component: Activity Keywords:
Cc:

Description

WP 4.2.2 and BP 2.3.2.1

@imath I just found "the bad guy": if you compose a blog post with WP text editor and if you include a...

­

...that post will not be recorded in activity. I was able to reproduce the problem with one word only containing the soft hyphen.

Change History (7)

#1 @schwarzaufweiss
3 years ago

  • Keywords needs-testing removed

#2 @imath
3 years ago

  • Keywords reporter-feedback added

It may not be the bad guy :(

Just tested it my post is like this:
https://cldup.com/FVpq9juDS4.png

I get an activity without the ­ :

https://cldup.com/XZfWRT3Bek.png

Have you tried with a "twenty" theme and no other plugins activated ?

Last edited 3 years ago by imath (previous) (diff)

#3 @hnla
3 years ago

  • Keywords reporter-feedback removed

I can't re-produce the issue on BP stable tag so I doubt this is a factor in whatever the issue is. This ticket I think relates to another and needs linking to as at the moment it's a little orphaned and it's not clear what the actual original issue is?

fwiw the soft hyphen has had a chequered history and not really been a stable implementation in the specs also it might be worth checking whether numeric entities work any better.

#4 @schwarzaufweiss
3 years ago

@imath

Yes, same with twenty fourteen but I have to test without other plugins...

#5 @schwarzaufweiss
3 years ago

@hnla

Thanks for your reply. Yes, it's the same issue for me while using no 173.

Last edited 3 years ago by schwarzaufweiss (previous) (diff)

#6 @r-a-y
23 months ago

  • Severity changed from normal to minor

I also cannot duplicate this on trunk.

I tried writing a blog post with only the ­ character and the post recorded in the activity stream, however no activity content showed up.

Something interesting to note is the WP blog post also doesn't show any content, but in the DB, the ­ character is recorded; in the BuddyPress activity table, ­ is not recorded, which means it is being stripped out in BuddyPress somewhere by one of our filters.

I guess we still have to look into what is stripping out the ­ character in the BP activity table, however, the main issue of the blog post not being recorded is not occurring in BP 2.5.

#7 @DJPaul
22 months ago

  • Milestone changed from Awaiting Review to Future Release
Note: See TracTickets for help on using tickets.