Skip to:

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6542 closed defect (bug) (worksforme)

Profile Field showing up in Account Details but missing in backend

Reported by: aethermage's profile Aethermage Owned by:
Milestone: Priority: highest
Severity: critical Version: 2.3.2
Component: (not sure) Keywords: 2nd-opinion needs-patch needs-refresh
Cc: ejarnold89@…



I am experiencing what I believe is a bug when it comes to the Profile Fields section of the Profile setup in BuddyPress. I have created Profile Fields in Base (Primary) and all of them show up in the Profile Details section of the Register page in the front end, except for one Profile Field that shows up in the Account Details section of the Register page.

I really need to delete the profile field that shows up in the wrong section, in Account Details because it has typos and users are complaining that they can't sign up because of it. I never even created the profile field in Account Details because I do not know if there's even a way to access Account Details.

I can view the profile field in the front end but in the backend I can view all the other profile fields except for this one. Please help fix this bug so that I can view the profile field in its right place and delete it. (By the way, it is NOT the Name profile field, what I am refering to is just a custom one I created).

I tried uninstalling BuddyPress and reinstalling it but was met with the exact same settings...

Attachments (1)

BuddyPress Ticket.png (81.2 KB) - added by Aethermage 9 years ago.
Screenshot of problem

Download all attachments as: .zip

Change History (8)

9 years ago

Screenshot of problem

#1 @boonebgorges
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Sorry to hear that you're having troubles.

What you're showing in the screenshot is not a real profile field. It's likely a field that is being created by a "humanity" plugin, which is meant to catch spambots. It is not generated by BuddyPress itself. Look through your plugins for one that might be causing this.

#2 @Aethermage
9 years ago

  • Keywords needs-refresh added
  • Milestone set to Awaiting Review
  • Resolution invalid deleted
  • Status changed from closed to reopened

Thank you for your reply!

I actually created this profile field myself to emulate a Captcha type field since I could not find what I needed to do the same thing. I spelt it wrong and now users are having problems understanding what they're supposed to do. I created it in the 'Profile Field's section but it is no longer visible there with the other fields in the backend.

So my problem is that I created the field and now need to edit/delete it but am unable because it will not appear in 'Profile Fields' and I have no idea how to edit Account Details. I have navigated the site and done research...

#3 @boonebgorges
9 years ago

Field management takes place in Dashboard > Users > Profile Fields. Is this what you're talking about?

#4 @Aethermage
9 years ago

Yes, that is where I created all the profile fields that are visible under Profile Details on the Register page. The profile field that resembles a captcha was created by myself but for some odd reason it appears under Account Details on the page and is missing from Dashboard > Users >Profile Fields so I am unable to edit/delete it.

#5 @boonebgorges
9 years ago

BP profile fields cannot appear in the Account Details section. A field can only appear in the section shown in your screenshot by hooking to the 'bp_account_details_fields' or 'bp_after_account_details_fields' actions. So this field must be being created by a plugin, or by your theme. It may also be the case that you created a field with the same name, but it cannot be the case that this field is what you're seeing in this location. Please verify that you don't have any plugins causing this by deactivating plugins other than BuddyPress, and/or by switching to a WP default theme like Twenty Fifteen.

#6 @Aethermage
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Thank you @boonebgorges for your help.

I deactivated all my plugins apart from BuddyPress and the field was indeed missing telling me that BuddyPress was not the problem. I activated one plugin at a time and when I reached WangGuard (anti-spam plugin) I realized that it was WangGuard that was causing the problem. I went into the configuration and was able to delete and create a new security 'captcha' style question according to my liking. So I believe this solved the problem!

Thank you very much for your help. I really appreciate it. :)

#7 @boonebgorges
9 years ago

Glad you've got it sorted out!

Note: See TracTickets for help on using tickets.