Skip to:
Content

BuddyPress.org

Opened 4 years ago

Closed 4 years ago

#6444 closed defect (bug) (no action required)

bp_detect_theme_compat_with_current_theme(), bp_core_load_template() don't work for themes with /bp-legacy copied files inside them

Reported by: lenasterg Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

Hi.
I noticed that the bp_detect_theme_compat_with_current_theme() and bp_core_load_template() aren't compatible with themes which follow the guidelines from https://codex.buddypress.org/themes/theme-compatibility-1-7/a-quick-look-at-1-7-theme-compatibility/#overloading-template-compatibility-theme-files and have a copy from bp-legacy/ files into either theme's /buddypress subfolder or theme/community subfolder.

It seems to me as a bug. Attached is the suggested patch.

Attachments (1)

bp-core-load-templates.patch (2.2 KB) - added by lenasterg 4 years ago.

Download all attachments as: .zip

Change History (2)

#1 @lenasterg
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.