Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 4 years ago

#6360 closed defect (bug) (fixed)

Managing signups in a multisite environment: Permission problem

Reported by: henry.wright Owned by: johnjamesjacoby
Milestone: 2.5 Priority: normal
Severity: major Version: 2.0
Component: Administration Keywords: has-patch
Cc: roger@…, mikeymike81@…

Description

If a user registers via the front end and doesn't activate their account through the email that is sent out, admins are given the opportunity to manage them through the Users > Manage Signups screen. Logged in as super admin, after clicking 'Activate', I get the message:

You do not have sufficient permissions to access this page.

The user remains in pending state.

Steps to reproduce:

  1. Go to the front-end registration form and register a dummy user.
  2. Log into the network dashboard as super admin.
  3. Go to Users > Manage Signups
  4. Click 'Activate' under the dummy user's username

Attachments (1)

6360.patch (551 bytes) - added by imath 4 years ago.

Download all attachments as: .zip

Change History (16)

#1 @rogercoathup
5 years ago

  • Cc roger@… added

To confirm the problem -- we can reproduce on our sites.

#2 @johnjamesjacoby
5 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 2.3
  • Owner set to johnjamesjacoby
  • Severity changed from normal to major
  • Status changed from new to accepted

I'll look at this soon, since I've touched this code most recently probably.

#3 @r-a-y
5 years ago

  • Keywords reporter-feedback added; needs-patch removed

Is this still an issue?

I just tried henry.wright's steps to duplicate and cannot confirm on trunk.

When I click on "Activate", I get taken to the "Activate Pending Accounts" page asking me to confirm my choice before activating the account in question.

Last edited 5 years ago by r-a-y (previous) (diff)

This ticket was mentioned in Slack in #buddypress by djpaul. View the logs.


5 years ago

#5 @imath
5 years ago

Just tested, i confirm like @r-a-y i'm able as a super admin to activate/resend/delete a signup on multisite config, having BuddyPress network activated.

#6 @DJPaul
5 years ago

  • Milestone changed from 2.3 to Under Consideration

There is a 2-2 split between people who have reported recreating the issue, and those who can't. I am moving this back to Under Consideration while we investigate this further.

#7 @CodeMonkeyBanana
5 years ago

  • Cc mikeymike81@… added

I have this same issue. There is no way to activate pending users from admin if BP_ENABLE_MULTIBLOG is enabled. It just gives the general permission error.

If BP_ENABLE_MULTIBLOG is false then in bp-members-admin.php on line 1863 this function will execute:

public function signups_admin_manage( $action = '' )

However, if If BP_ENABLE_MULTIBLOG is true then this function is not hit. Callstack is not much help here as it's failing before it gets to this thread of code.

Current workaround: This plugin offers the same functionality and works https://wordpress.org/plugins/unconfirmed/ only seems to work for network admin though.

Last edited 5 years ago by CodeMonkeyBanana (previous) (diff)

#8 @r-a-y
5 years ago

CodeMonkeyBanana - I read your forum post and your issue is actually #6371.

Everybody else - Do you have BP_ENABLE_MULTIBLOG set to true?

#9 @rogercoathup
5 years ago

Yes, we have BP_ENABLE_MULTIBLOG set to true

#10 @r-a-y
5 years ago

Yes, we have BP_ENABLE_MULTIBLOG set to true

See #6371 instead.

#11 @henry.wright
5 years ago

I have BP_ENABLE_MULTIBLOG set to true too.

#12 @r-a-y
5 years ago

  • Keywords reporter-feedback removed
  • Milestone Under Consideration deleted
  • Status changed from accepted to closed
  • Version changed from 2.2.1 to 2.0

Cool, marking as a duplicate of #6371.

Thanks for confirming everyone and please do test the patch there as well.

#13 @imath
4 years ago

  • Keywords has-patch added
  • Milestone set to 2.5
  • Status changed from closed to reopened

I've found a way to reproduce this bug without BP_ENABLE_MULTIBLOG set to true

You simply need to only activate BuddyPress on the root blog and not network widely. Then go into the network admin / Manage Signups and clicking on one of the action links will fail.

I think the reason is due to how we add the users submenu. And i believe, this menu should only be displayed at the level where BuddyPress is activated. If it's network activated > network admin, else blog's admin.

Using the attached patch is fixing the issue for me, but i still need to test it on regular config. I'm wondering if it's also fixing the BP_ENABLE_MULTIBLOG mode (#6371).

@imath
4 years ago

#14 @DJPaul
4 years ago

This fixes for everything except multiblog.

#15 @djpaul
4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 10411:

Members wp-admin: only show "Manage Signups" when appropriate.

Using BuddyPress on a multisite but only activated on the root blog
caused an invalid link when inside the Network Admin screens (it was a
Network Admin URL rather than site-specific).

This menu should only be displayed at the level where BuddyPress is
displayed.

Fixes #6360, props imath

Note: See TracTickets for help on using tickets.