Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 4 years ago

#6281 closed enhancement (maybelater)

Cannot return to a page > 1 of a directory.

Reported by: jreeve Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords: needs-patch, trac-tidy-2018
Cc:

Description

To reproduce:

  • Navigate to a directory (members, groups, etc) that has more than one page.
  • Go to the second, third, or Xth page of that directory.
  • Follow a link from that directory, like a link to a member or a group.
  • Press your browser's "back" button to return to the directory.
  • Notice how you're not on the 2nd, third, or Xth page of the directory, but on the first.

It'd be great to use URL hashes or some other technology so that users can return to the page they were on, and not have to start over.

Change History (4)

#1 @boonebgorges
7 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release
  • Type changed from defect (bug) to enhancement

Yeah. It would be nice to use window.history.pushState() for all of our AJAX pagination. A fun task for someone who wants to write a patch.

#2 @DJPaul
5 years ago

  • Component changed from API to Core

#3 @DJPaul
4 years ago

  • Keywords trac-tidy-2018 added

We're closing this ticket because it has not received any contribution or comments for at least two years. We have decided that it is better to close tickets that are good ideas, which have not gotten (or are unlikely to get) contributions, rather than keep things open indefinitely. This will help us share a more realistic roadmap for BuddyPress with you.

Everyone very much appreciates the time and effort that you spent sharing your idea with us. On behalf of the entire BuddyPress team, thank you.

If you feel strongly that this enhancement should still be added to BuddyPress, and you are able to contribute effort towards it, we encourage you to re-open the ticket, or start a discussion about it in our Slack channel. Please consider that time has proven that good ideas without contributions do not get built.

For more information, see https://bpdevel.wordpress.com/2018/01/21/our-awaiting-contributions-milestone-contains/
or find us on Slack, in the #buddypress channel: https://make.wordpress.org/chat/

#4 @DJPaul
4 years ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to maybelater
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.