Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

#6202 closed defect (bug)

Wrong group forum informations

Reported by: danbp's profile danbp Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Forums Keywords:
Cc: danco38@…

Description

BP 2.2.0 stable, bbp 2.5.4, Twenty Thirteen and BuddyPress Default Data plugin.

While testing around this user question, i stumbled on wrong group information.

Group status doesn't revert private/public. See screenshots.

Also, topics published under private hood should stay private and never appear publicly if the group becames public.

As group admin, i create a new group, made it private and published a topic. Was OK.

I went to another group i'm also admin of to publish in that group forum. The group hasn't a forum at that time, but the group forum tab showed the previous forum. In the header was the correct group name and in the edit part i saw the previous group name. Tried to publish anyway and got a missing forum ID.
Added the forum and all went correctly.

I guess that when a group hasn't yet a forum active, it would be preferable to have a warning saying that the group has no forum instead showing a part of another existing forum.

Attachments (2)

private-public1.jpg (35.6 KB) - added by danbp 9 years ago.
private-public2.jpg (37.1 KB) - added by danbp 9 years ago.

Download all attachments as: .zip

Change History (5)

@danbp
9 years ago

@danbp
9 years ago

#1 @danbp
9 years ago

To reproduce

Create a group, a forum and make them private.
Publish a topic to generate an activity.
Return to settings and make the group public.
Disconnect and go the this group activity: empty ! Forum: empty.
Login as another user.
Go to the group: activity & empty are empty.
Join the group and everything is showing.

#2 @DJPaul
9 years ago

  • Milestone changed from Awaiting Review to Under Consideration

We're not ignoring this, @danbp - just haven't tested. Will look soon.

#3 @r-a-y
9 years ago

  • Milestone Under Consideration deleted
  • Status changed from new to closed
  • Version 2.2 deleted

Marking as a duplicate of #BB2599.

Note: See TracTickets for help on using tickets.