Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 5 years ago

#6160 closed defect (bug)

BuddyPress adds a filter 'wp_mail_from_name' on loading

Reported by: kashmiri Owned by:
Milestone: Priority: high
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

Based on https://buddypress.org/support/topic/buddypress-incorrectly-overwrites-email-message-headers/#post-231491 - please refer there.

BuddyPress ads a filter 'wp_mail_from_name' when loading.

This filter is also used by other plugins - applied just before sending a mail and then removed. When sender name ("from") is changed from the default "WordPress", plugins do not apply the filter, primarily in order to ensure compatibility with other plugins such as wp-mail-smtp.

BuddyPress should only apply this and associated filters at the time of sending the mail and then remove it afterwards - instead of activating it globally and permanently.

Change History (1)

#1 @r-a-y
5 years ago

  • Milestone Awaiting Review deleted
  • Status changed from new to closed

Duplicate of #4689.

Note: See TracTickets for help on using tickets.