Skip to:

Opened 3 years ago

Closed 6 weeks ago

#6145 closed enhancement (maybelater)

BP 2.2 beta 2 - member-type can be changed by member on their extended-profile page

Reported by: chubbycrow Owned by:
Milestone: Priority: low
Severity: normal Version:
Component: Members Keywords: trac-tidy-2018
Cc: bill@…


Hi all. @r-a-y suggested posting here about this issue thinking it may be a bug, so I'll just copy what I originally wrote on the support forums:

This new member-types feature is looking really great so far. I noticed though that a member can change their own member-type on the extended-profile back-end page. Is this intended to remain the default behavior?

I can see reasons for both approaches (either under admin-, or under member-control), but I would think that allowing members to choose their own type might have undesired results. For example, in the ‘student’/’teacher’ scenario, presenting a page that lists teachers might need regular oversight. What do you think?


WP 4.1
child theme of Twentythirteen

Change History (7)

#1 @imath
3 years ago

Thanks for your interesting feedback.

A possible enhancement for the future would probably be to include some filterable capabilities when registering the member_types taxonomy.

I'll let boonebgorges reply more precisely, but I don't think the fact the user can edit his own type is a bug.

#2 @slaFFik
3 years ago

Anyway developers should be able to filter that out, so users won't be able to edit their member type.

#3 @Paul Gibbs
3 years ago

  • Milestone changed from Awaiting Review to Future Release
  • Priority changed from normal to low
  • Type changed from defect (bug) to enhancement

This is working as intended for this first version; the implementation is being kept simple so we can see how developers start to use the feature. (For example, you have to add new member types via code, there isn't a UI for it). Feedback like this will help influence how we iterate on this in future releases, so thanks for your feedback.

#4 @Boone Gorges
3 years ago

A possible enhancement for the future would probably be to include some filterable capabilities when registering the member_types taxonomy.

Yes, that's not a bad idea.

I agree with what DJPaul has said here. Let's try to do something like this for 2.3. In the meantime, here's some sample code that you can adapt to hide the metabox from certain users. In this case, I'm allowing only 'bp_moderate' users (ie, admins) to view it, but you can do whatever you'd like.

function bp6145_remove_member_type_metabox() {
	if ( current_user_can( 'bp_moderate' ) ) {

	remove_meta_box( 'bp_members_admin_member_type', get_current_screen()->id, 'side' );
add_action( 'bp_members_admin_user_metaboxes', 'bp6145_remove_member_type_metabox' );

#5 @chubbycrow
3 years ago

  • Cc bill@… added

Thanks very much to each of you for the clarification, and for being so open to input. Special thanks to @boonebgorges for crafting the snippet! It's much appreciated.

#6 @Paul Gibbs
6 weeks ago

  • Keywords trac-tidy-2018 added

We're closing this ticket because it has not received any contribution or comments for at least two years. We have decided that it is better to close tickets that are good ideas, which have not gotten (or are unlikely to get) contributions, rather than keep things open indefinitely. This will help us share a more realistic roadmap for BuddyPress with you.

Everyone very much appreciates the time and effort that you spent sharing your idea with us. On behalf of the entire BuddyPress team, thank you.

If you feel strongly that this enhancement should still be added to BuddyPress, and you are able to contribute effort towards it, we encourage you to re-open the ticket, or start a discussion about it in our Slack channel. Please consider that time has proven that good ideas without contributions do not get built.

For more information, see
or find us on Slack, in the #buddypress channel:

#7 @Paul Gibbs
6 weeks ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to maybelater
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.