Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#6114 closed enhancement

Global cache group improvements

Reported by: johnjamesjacoby's profile johnjamesjacoby Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

BuddyPress currently relies on the 'bp' cache group in many places where a more specific group would be more appropriate.

For example

  • The entire Blogs component uses this group, instead of its own bp_blogs group.
  • bp_activity_sitewide_front uses bp rather than bp_activity
  • Friends uses bp for member relationships.
  • Groups uses bp for total group counts and user memberships.
  • XProfile uses bp for groups and visibility levels.

I think most of these would benefit from having/using their own global cache group.

Change History (5)

#2 @r-a-y
9 years ago

+1. This is long overdue!

#3 @r-a-y
9 years ago

  • Keywords 2nd-opinion removed
  • Milestone changed from 2.3 to 2.4

#4 @r-a-y
9 years ago

  • Keywords needs-patch needs-testing removed
  • Milestone 2.4 deleted
  • Status changed from new to closed

Going to mark this as a duplicate of #6341 as that ticket has some commits to it and is essentially the same issue.

Will copy this ticket description over.

#5 @DJPaul
8 years ago

  • Type changed from task to enhancement
Note: See TracTickets for help on using tickets.