Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 4 years ago

#6074 closed defect (bug) (no action required)

Accept a pending group membership request: Wordpress failure notice

Reported by: bcbella1 Owned by: DJPaul
Milestone: Priority: high
Severity: normal Version: 2.1
Component: Groups Keywords: reporter-feedback
Cc:

Description

When a user requests to be accepted into the group and the group chooses to either accept or reject that member, a wordpress failure notice occurs. I have tried different themes and deactivating other plugins, nothing worked. I have no idea what to do

Change History (9)

#1 @imath
6 years ago

  • Keywords reporter-feedback added

hi bcbella1

Thanks for your feedback. I wasn't able to reproduce. Could you paste the content of the notice in a comment to this ticket ?

#3 in reply to: ↑ 2 @imath
6 years ago

Replying to bcbella1:

When I try to accept or reject someone into a group, this error appears http://dormnextdoor.com/schools/palm-beach-atlantic-university/admin/membership-requests/accept/2/?_wpnonce=46e93a232e

Thanks for your reply, but this link doesn't help me a lot, as i'm not logged in as the "admin" user. Could you simply copy and paste the error notice ?

#4 @bcbella1
6 years ago

Right, forgot about that, sorry. The page literally just says:

Are you sure you want to do this?

Please try again.

And if you click try again it sends your right back to the manage membership page

#5 @imath
6 years ago

Looks like the security nonce checks is failing. I've tested again, and everything works fine with me.

I've noticed, something seems to be wrong with your config. For instance if you go there
http://dormnextdoor.com/
Then click on the 2nd activity (the X days ago link), something is adding an extra query part:
the link is http://dormnextdoor.com/members/admin/activity/5/?/the-line/p/5/
it should be http://dormnextdoor.com/members/admin/activity/5/

To see if the nonce issue is specific to groups membership request or more global, you can try to delete the single activity from the first link (the wrong one). Then the second link (the good one)

In any case, the best is to deactivate all plugins and activate a WordPress default theme to check if your theme or a particular plugin is interfering. Before doing so, don't forget to backup your files and especially your db. It will be easier to come back to your config.

#6 follow-up: @bcbella1
6 years ago

I tried everything you said and nothing is working unfortunately :/ what would you recommend the next step being?

#7 in reply to: ↑ 6 @imath
6 years ago

Replying to bcbella1:

I tried everything you said and nothing is working unfortunately :/ what would you recommend the next step being?

Meaning you also have a 'Are you sure you want to do this?' message when you try to delete an activity from its single view ? And deactivating plugins, activating a default theme does not have any effects ?

I think, here, we need to know how to reproduce in order to isolate the bug if any and correct it. It seems to me that BuddyPress might not be responsible for the issue you reported as i wasn't able to reproduce.

So you can, on a local environment (MAMP/WAMP/LAMP), test a fresh install of latest WordPress and latest BuddyPress and if you succeed to reproduce, then report the different steps you made to make it happen, else i advise you to ask for help in the BuddyPress support forums

#8 @DJPaul
6 years ago

  • Milestone Awaiting Review deleted
  • Owner set to DJPaul
  • Status changed from new to reviewing

Going to close this for now as we can't recreate the problem, but we will re-open if we receive more reports, or find out how to recreate the issue.

#9 @tw2113
4 years ago

  • Resolution set to invalid
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.