Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#6048 closed defect (bug) (wontfix)

JS bug in "delete selected privated messages" (default_theme)

Reported by: handbike Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.2
Component: Templates Keywords:
Cc:

Description

There is a bug in the javscript for deleting the selected private messages in the default_theme:

global.js line 1220 has wrong brackets:
if ( -1 == jq.inArray( this.id ), Array( 'delete_sentbox_messages', 'delete_inbox_messages' ) ) {

BP-Legacy, buddypress.js line 1481 is correct:
if ( -1 === jq.inArray( this.id, Array( 'delete_sentbox_messages', 'delete_inbox_messages' ) ) ) {

Cheers, Dirk

Change History (4)

#1 @DJPaul
7 years ago

  • Milestone changed from Awaiting Review to Future Release
  • Version changed from 2.1 to 1.2

Confirmed that this only affects BP-Default. Updating BP-Default isn't a high priority for us at the moment, but if anyone wants to be us to submitting a fix, you can find BP-Default on Github: https://github.com/buddypress/BP-Default

#2 @DJPaul
5 years ago

  • Component changed from Appearance - Template Parts to Templates

#3 @DJPaul
4 years ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Closing most tickets related to BP-Default and BP-Legacy, since the upcoming BP-Nouveau template pack (planned for 3.0) will make these redundant.

#4 @DJPaul
4 years ago

Closing most tickets related to BP-Default and BP-Legacy, since the upcoming BP-Nouveau template pack (planned for 3.0) will make these redundant.

Note: See TracTickets for help on using tickets.