Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

#5966 closed defect (bug) (no action required)

Problems in Group Blog Post and Reply

Reported by: shahejad's profile shahejad Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: Groups Keywords: reporter-feedback
Cc:

Description

I have came across the strange issue in my buddypress theme which uses the bp-default as a parent theme. When some one posts a long reply to a group blog post it just truncates the text and provides a [Read More] link. But when I click on it, the content just disappears. I have changed the code in bp-default/_inc/ajax.php

Regular Function:

// Activity content retrieved through AJAX should run through normal filters, but not be truncated remove_filter( 'bp_get_activity_content_body', 'bp_activity_truncate_entry', 5 ); 
$content = apply_filters( 'bp_get_activity_content_body', $activity->content );

exit( $content );

}

New Function:

	// Activity content retrieved through AJAX should run through normal filters, but not be truncated
	remove_filter( 'bp_get_activity_content_body', 'bp_activity_truncate_entry', 5 );
	$content = apply_filters( 'bp_get_the_thread_message_content', $activity->content);
	echo $content;
    exit( );
}

1. Before Clicking [Read More]

http://s15.postimg.org/5hanosve3/Read_More_1.png

2. After Clicking [Read More]
http://s7.postimg.org/tys3u0otn/Read_More_2.png
Kindly check it and provide me the information that whether its a bug or something is wrong in my child theme.

Change History (5)

#1 @shahejad
9 years ago

Sorry I just forgot to mention that changing the code in ajax.php has resolved the issue for me. But its the change in buddypress core module that's why I want to double check.

#2 @DJPaul
9 years ago

  • Keywords reporter-feedback added; needs-testing dev-feedback 2nd-opinion removed

Hi shahejad

Does the problem go away if you use just the BP-Default theme? Are you able to test? That would let us know if the problem is with BuddyPress, or in your theme.

#3 @DJPaul
9 years ago

  • Component changed from Core to Groups
  • Priority changed from highest to normal
  • Severity changed from major to normal

#4 @shahejad
9 years ago

Hey DJPaul,

Thanks for the help. It seems that there is something wrong in my theme. The issue goes away once I enable the default theme. I have to customize my theme as per the new buddypress version.

Sunny

#5 @DJPaul
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

OK - if you can't figure out the issue, open up a ticket on the support forum and we'll do our best to help. Thanks!

Note: See TracTickets for help on using tickets.