Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

#5930 closed defect (bug) (worksforme)

Private message sending: autocomplete username doesn't match typed letters

Reported by: sgr33n's profile SGr33n Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords: reporter-feedback
Cc:

Description

Hi,

Today I was testing the private message sending and the autocomplete username field and I figured out that the first returned username doesn't match at all with entered words, it just matches the second part after the first letter.

E.g.

Typed pat
returned:
-misscat
-patana
-patanela

Attachments (1)

autocomplete-sendto.png (84.7 KB) - added by SGr33n 9 years ago.
Screenshot of the Wrong Autocomplete Bug

Download all attachments as: .zip

Change History (4)

@SGr33n
9 years ago

Screenshot of the Wrong Autocomplete Bug

#1 @imath
9 years ago

  • Keywords reporter-feedback added

Hi SGr33n,

I'm not sure autocomplete is wrong. Since 2.1, the autocomplete is now using the BP_Members_Suggestions class meaning it's using BP_User_Query, meaning, if xprofile component is active it will not only look in user_login or user_nicename but also in user's profile fields.

Could you check if Misscat have a xProfile field value containing %pat% ?

If so then i think it's not a bug

#2 @SGr33n
9 years ago

You're right she has. So it's ok :)
Sorry!

#3 @imath
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

No problem at all :) I'm closing this ticket.

Note: See TracTickets for help on using tickets.