Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#5909 closed defect (bug) (fixed)

Logging out does not clear cookies

Reported by: r-a-y Owned by: r-a-y
Milestone: 2.1.1 Priority: normal
Severity: normal Version: 2.1
Component: Appearance - Template Pack Keywords: has-patch commit
Cc:

Description (last modified by r-a-y)

Originally reported by Ypswytch:
https://buddypress.trac.wordpress.org/ticket/5889#comment:13

When a user logs out, buddypress.js attempts to clear all cookies. However, this now fails with BP 2.1.

The problem is when we enqueued our JS assets, we upgraded jquery.cookie to 1.4.1.

v1.4.1 has a new routine to remove cookies:
$.removeCookie('name', { path: '/' });

We are currently doing this:
$.cookie('name', null, { path: '/' });

Which doesn't clear the cookie anymore. Attached patch switches all our clear cookie calls to this updated routine.

Attachments (1)

5909.01.patch (1.1 KB) - added by r-a-y 5 years ago.

Download all attachments as: .zip

Change History (7)

@r-a-y
5 years ago

#1 @r-a-y
5 years ago

  • Description modified (diff)

#2 @r-a-y
5 years ago

  • Description modified (diff)

#3 @boonebgorges
5 years ago

  • Keywords commit added

Good find, r-a-y.

#4 @r-a-y
5 years ago

  • Owner set to r-a-y
  • Resolution set to fixed
  • Status changed from new to closed

In 9055:

bp-legacy: Properly clear cookies when logging out.

When a user logs out, buddypress.js attempts to clear all cookies. However,
this now fails with BP 2.1.

The problem is when we enqueued our JS assets (#5208), we upgraded
jquery.cookie to 1.4.1. v1.4.1 uses a new routine to clear cookies.

This commit updates our clear cookies calls to this updated routine.

Fixes #5909 (2.1-branch).

#5 @r-a-y
5 years ago

In 9056:

bp-legacy: Properly clear cookies when logging out.

When a user logs out, buddypress.js attempts to clear all cookies. However,
this now fails with BP 2.1.

The problem is when we enqueued our JS assets (#5208), we upgraded
jquery.cookie to 1.4.1. v1.4.1 uses a new routine to clear cookies.

This commit updates our clear cookies calls to this updated routine.

Fixes #5909 (trunk).

This ticket was mentioned in Slack in #buddypress by r-a-y. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.