Skip to:
Content

BuddyPress.org

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#590 closed defect (bug) (duplicate)

Avatar cropping tools non-existent

Reported by: benny148148's profile benny148148 Owned by:
Milestone: Priority: major
Severity: Version:
Component: Keywords:
Cc:

Description

This is an issue with both the user's avatar upload and the group avatar upload. I've created screenshots of the group avatar upload problem below. Essentially what happens is neither the cropping tools nor the "crop preview" image show up after a user uploads an image. Uploading is not the issue, it's the cropping/saving that presents the problem.

This first image is how it should look (image taken from testbp.org)
http://www.screencast.com/t/7kXuJ9A5jT

The following image is what is shown after I upload a group image (the same thing happens for user uploads too). As you will see, there is no crop tool or crop preview:
http://www.screencast.com/t/LyIZ3Axowd

When "crop thumbnail and continue" is clicked, it simply takes the user to the following image (again, no crop tools or crop preview):
http://www.screencast.com/t/QYFIaiCPBS

Finally, after "crop full size and save" is clicked, the group avatar becomes a pure black square, as if the image was never uploaded:
http://www.screencast.com/t/QYFIaiCPBS

I've checked and the images (both user and group avatars) are being uploaded to the correct directories, and all permissions are correctly set to 755. This is purely an avatar upload issue.

Hopefully that is enough information to get this issue resolved. If you need any more info please let me know, I'll keep checking trac for updates.

Change History (6)

#1 @apeatling
15 years ago

First of all - do you have the GD image library installed on your server?

#2 @apeatling
15 years ago

  • Priority changed from critical to major

#3 @benny148148
15 years ago

Yes, both GD image library and Image Magick are installed...and I'm running on a VPS.

#4 @benny148148
15 years ago

Here's a video of the problem...it will give you a better idea of what is happening. When the first "crop" button is clicked, the same image that you are cropping "glides" in from the bottom of the first image, but nothing is shown as far as crop tools and/or crop preview.

http://www.screencast.com/t/9Z9wGlhj

#5 @apeatling
15 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Sup of #544

Note: See TracTickets for help on using tickets.