Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5868 closed defect (bug) (fixed)

Groups Dashboard not populating members.

Reported by: SeeingBlueS2 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: Groups Keywords: reporter-feedback
Cc:

Description

Related Topic: http://buddypress.org/support/topic/group-edit-dashboard-broken/

As stated in the topic above there is an issue with groups. I am running Buddypress 2.0.2 and Wordpress 3.9.2

When creating a group, everything shows fine on the frontend, but when I open the group in the dashboard to edit them, no members show up.

http://oi58.tinypic.com/25z4e3d.jpg
http://oi62.tinypic.com/4ht5ky.jpg

Groups did work fine for me until I ran Tools > Buddypress > Data to Repair > Count groups for each user. I don't really want to repeat a lot of the information already detailed in the above thread so please read over it carefully.

Thank you.

Change History (9)

#1 @r-a-y
6 years ago

  • Component changed from Core to Groups
  • Keywords reporter-feedback added
  • Priority changed from high to normal
  • Severity changed from major to normal

SeeingBlueS2 - I can't duplicate this issue.

Just tried running the "Count groups for each user" tool and returned to a group on the "Groups" admin page. The members are still listed.

I would check your wp_bp_groups_members DB table to see if the appropriate entries are recorded in the database.

Also, disable any unnecessary BuddyPress plugins to see if that helps.

#2 @imath
6 years ago

  • Component changed from Groups to Core
  • Keywords reporter-feedback removed
  • Priority changed from normal to high
  • Severity changed from normal to major

Hi SeeingBlueS2,

Thanks for your feedback.

I confirm r-a-y's comment. I've tried on my side, everything works fine using BuddyPress 2.0.2 and WordPress 3.9.2.

I've used the count repair tool, and still no problem.

If you can temporarly define( 'WP_DEBUG', true); in your wp-config.php file and go in the Group admin screen, maybe you could see an error and report it in a comment to this ticket.

PS: don't forget to define( 'WP_DEBUG', false); once done.

#3 @imath
6 years ago

  • Component changed from Core to Groups
  • Keywords reporter-feedback added
  • Priority changed from high to normal
  • Severity changed from major to normal

#4 @SeeingBlueS2
6 years ago

Sadly it does not report any errors. Is there something else we can check?

Everything used to work fine for me aswell. Sad thing is if I disable all other plugins and use the twentyfourteen theme it still does not work.

r-a-y, I checked the DB and it is working properly. I added a member to the group and even that works.

Just as an additional note. I cloned my site into a test environment. Deleted ALL plugins and switched to tweentythirteen theme. Reinstalled Buddypress and I am still having the same problem.

Last edited 6 years ago by SeeingBlueS2 (previous) (diff)

#5 @r-a-y
6 years ago

If the members are populated in the wp_bp_groups_members table, then the issue must be occurring at the query level.

Are you using a caching plugin by chance?

We need to be able to duplicate your issue, so if it is possible to start on a fresh, dev environment to try and recreate the bug with steps for us to replicate that would be most helpful.

#6 follow-up: @SeeingBlueS2
6 years ago

Well I am not sure how to recreate it, just tried on a fresh install and it's working. I am not using a caching plugin. Just to be clear though the frontend is working and displaying properly, it's just the dashboard that's having this issue.

What is left behind when buddypress plugin is deleted? Is there a file or something I can clear out and replace?

#7 in reply to: ↑ 6 @imath
6 years ago

Replying to SeeingBlueS2:

What is left behind when buddypress plugin is deleted? Is there a file or something I can clear out and replace?

Nothing is deleted when BuddyPress is deleted.

In Group's Administration, the query to get members of the group is using the 'alphabetical' order.
In Members tab of the groups front end screen, the default order is 'last_joined'. So if you see members on front end and not in Group's administration, then this might be due to order and a specific BuddyPress setting.

On Group's members tab (front end), you should be able to filter the members alphabetically. If no members are displayed, then, you should check the BuddyPress setting 'Enable BuddyPress to WordPress profile syncing'. If the checkbox is not active, then there can be a case i've succeeded to reproduce your bug : it has to do with the xProfile base field.

If the option (wp_options table) bp-xprofile-fullname-field-name is not set or has a different value than the base field in wp_bp_xprofile_fields.name (should be the first line), then it may be the root of your problem

Could you check in this direction ?

#8 @SeeingBlueS2
6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

"Enable BuddyPress to WordPress profile syncing" Fixed my problem. I thought this was checked and not sure how or why it was unchecked.

Thank you.

#9 @DJPaul
6 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.