Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 5 years ago

#5860 closed defect (bug) (fixed)

XProfile: Updating group order should purge 'xprofile_groups_inc_empty' cache

Reported by: r-a-y Owned by: r-a-y
Milestone: 2.1 Priority: normal
Severity: normal Version:
Component: Extended Profile Keywords: has-patch commit
Cc:

Description

On the "Users > Profile Fields" admin page, create a bunch of profile groups.

Next, go to your "Profile > Edit" page to view the profile group tabs. Everything should be all good.

Now, go back to the "Users > Profile Fields" admin page, and rearrange the Profile Groups in a different order. Then, navigate back to "Profile > Edit" on the frontend. The profile group tabs are not showing the newer order.

The problem is we are not clearing the cache when a Profile Group is reordered.

01.patch fixes this and includes a unit test.

Attachments (1)

5860.01.patch (1.7 KB) - added by r-a-y 5 years ago.

Download all attachments as: .zip

Change History (4)

@r-a-y
5 years ago

#1 @r-a-y
5 years ago

Forgot to mention that you need an object cache enabled to see the bug. The unit test should demonstrate the problem though.

#2 @boonebgorges
5 years ago

  • Keywords commit added

Good catch, r-a-y. Thanks!

#3 @r-a-y
5 years ago

  • Owner set to r-a-y
  • Resolution set to fixed
  • Status changed from new to closed

In 8986:

XProfile: Purge profile group cache when profile groups are reordered.

Commit also includes a unit test.

Fixes #5860.

Note: See TracTickets for help on using tickets.