Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 21 months ago

#582 closed enhancement (maybelater)

Relationship Mapping

Reported by: Jeff Sayre Owned by:
Milestone: Priority: major
Severity: Version:
Component: Activity Keywords: relationships, friends, trac-tidy-2018
Cc:

Description

Currently, BuddyPress offers a loosely two-way, reciprocal relationship indicator solely based on the notion of friendship. However, the relationships people have with one another on a social network extend beyond the nebulous catchall of "friend".

Being able to provide members with a way to more accurately describe their relationships would add more power to the BP platform. Such a relationship mapping feature could help users describe whether another member was a true friend, a fan, an acquaintance, a business partner, an intimate partner, a work colleague, a student, a professor, a client, a customer, and so on.

After all, I have many friends on the testbp.org site but I've never met them, I don't know what most of them look like, and have never talked to them before. Are all of these really my friends? Whether or not they become actual friends in the future is not the issue. The issue is, what is the nature of our relationship at this point in time.

Although there can be a 1:N relationship map between two people, I propose for version 1.0, letting each individual pick the single, best relationship indicator that describes a given association.

Future enhancements to this functionality could include:

  • the ability to set access levels depending on relationship type
  • the ability to choose more than one relationship type
  • the ability to group relationships by type
  • the ability to see a graphical representation of the relationship map
  • the ability to filter by relationship type

Change History (5)

#1 @(none)
10 years ago

  • Milestone Future Enhancements deleted

Milestone Future Enhancements deleted

#2 @jeffsayre
10 years ago

  • Milestone set to Future Release
  • Priority changed from minor to major

#3 @roydeanjr
10 years ago

  • Component set to Activity

+1

Couldn't you add or modify the friend field to be friend type? Then create a table of friend types or maybe even a query of the membership or whatever table contains the current relationship information such that not only is the possible friend types dynamic, it is not "dictated" by the site admins. Am I being clear?

Then a template loop would be to create either tabs or simply a pull-down with existing "friend types" pulled from the users list of friends. Include an option for not acquainted so that you can always get a list of every member at some point.

#4 @DJPaul
21 months ago

  • Keywords trac-tidy-2018 added

We're closing this ticket because it has not received any contribution or comments for at least two years. We have decided that it is better to close tickets that are good ideas, which have not gotten (or are unlikely to get) contributions, rather than keep things open indefinitely. This will help us share a more realistic roadmap for BuddyPress with you.

Everyone very much appreciates the time and effort that you spent sharing your idea with us. On behalf of the entire BuddyPress team, thank you.

If you feel strongly that this enhancement should still be added to BuddyPress, and you are able to contribute effort towards it, we encourage you to re-open the ticket, or start a discussion about it in our Slack channel. Please consider that time has proven that good ideas without contributions do not get built.

For more information, see https://bpdevel.wordpress.com/2018/01/21/our-awaiting-contributions-milestone-contains/
or find us on Slack, in the #buddypress channel: https://make.wordpress.org/chat/

#5 @DJPaul
21 months ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to maybelater
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.